net-firewall/iptables: Bump to version 1.8.0
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 9 Jul 2018 09:03:22 +0000 (11:03 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 9 Jul 2018 09:04:13 +0000 (11:04 +0200)
Package-Manager: Portage-2.3.41, Repoman-2.3.9

net-firewall/iptables/Manifest
net-firewall/iptables/iptables-1.8.0.ebuild [new file with mode: 0644]

index 9797bcf51154e2691cf4e30d9ee9a7869e44b742..d558eddc3ac2ba8249fa546e02dea28aa8278975 100644 (file)
@@ -1,3 +1,4 @@
 DIST iptables-1.4.21.tar.bz2 547439 BLAKE2B e30f25581a118b91781dcc02761d4c8c420fb19876ec9e8ade3aff22b574931065f9a1c1ec31983a444c406dd928c47673d02698553da85c3db4f31484b1597d SHA512 dd4baccdb080284d8620e6ed59beafc2677813f3e099051764b07f8e394f6d94ca11861b181f3cce7c55c66de64c1e2add13dc1a0b64e24050cd9fb7aea0689b
 DIST iptables-1.6.1.tar.bz2 620890 BLAKE2B b45ac26e1fb7e8b17a6df0afab3b6c0e2f0a5df9191367548136b3ce9aadc1bcb875b8bc0403e6f12fcf487054e96418f4ef34da827af8989fd4dcf83cd3cd8d SHA512 12280db6e6ef8e68da2537e9da59fc601790fd02b1ba38a37c90dbb56272018329dccb8be995f96ecd5d94fafa6043204f3e8f8ee96531685d9e3c55359d2ee8
 DIST iptables-1.6.2.tar.bz2 639785 BLAKE2B 3d129756fd33c8c73d56d57e3c5595896db86ded14834a45db21b964d82840b62216ce3cea4ae4960e8c5f0671df3cc6bfb222f68d29cf3a8c99e0eee14bf017 SHA512 04f22e969c794246b9aa28055b202638081cfb0bb4a5625c049a30c48ac84cdd41db12a53c5831398cfe47c8f5691aa02b30b0ae3b5afe0f20ec48cf86a799c0
+DIST iptables-1.8.0.tar.bz2 677980 BLAKE2B ce874572d736087f46ea5a6e393cf9b32bf7328efda0fd9faee94dfa11428fc0e124d5ed81329484032ac4ebe89b2604b26dbb135e152c0e0f4c74d88db52d00 SHA512 5f3fe4c15f02e29a2e6ee2905a242f450f8a3b51553618e0cdc59301c35b8bb663e8f2ea70dfcaed8d4e53192c01519906b60ff649385c693e0602622742890f
diff --git a/net-firewall/iptables/iptables-1.8.0.ebuild b/net-firewall/iptables/iptables-1.8.0.ebuild
new file mode 100644 (file)
index 0000000..7805193
--- /dev/null
@@ -0,0 +1,123 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# Force users doing their own patches to install their own tools
+AUTOTOOLS_AUTO_DEPEND=no
+
+inherit multilib systemd toolchain-funcs autotools flag-o-matic
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="https://www.netfilter.org/projects/iptables/"
+SRC_URI="https://www.netfilter.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+# Subslot tracks libxtables as that's the one other packages generally link
+# against and iptables changes.  Will have to revisit if other sonames change.
+SLOT="0/12"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="conntrack ipv6 netlink nftables pcap static-libs"
+
+COMMON_DEPEND="
+       conntrack? ( >=net-libs/libnetfilter_conntrack-1.0.6 )
+       netlink? ( net-libs/libnfnetlink )
+       nftables? (
+               >=net-libs/libmnl-1.0:0=
+               >=net-libs/libnftnl-1.1.1:0=
+       )
+       pcap? ( net-libs/libpcap )
+"
+DEPEND="${COMMON_DEPEND}
+       virtual/os-headers
+       >=sys-kernel/linux-headers-4.4:0
+       virtual/pkgconfig
+       nftables? (
+               sys-devel/flex
+               virtual/yacc
+       )
+"
+RDEPEND="${COMMON_DEPEND}
+       nftables? ( net-misc/ethertypes )
+"
+
+src_prepare() {
+       # use the saner headers from the kernel
+       rm -f include/linux/{kernel,types}.h
+
+       # Only run autotools if user patched something
+       eapply_user && eautoreconf || elibtoolize
+}
+
+src_configure() {
+       # Some libs use $(AR) rather than libtool to build #444282
+       tc-export AR
+
+       # Hack around struct mismatches between userland & kernel for some ABIs. #472388
+       use amd64 && [[ ${ABI} == "x32" ]] && append-flags -fpack-struct
+
+       sed -i \
+               -e "/nfnetlink=[01]/s:=[01]:=$(usex netlink 1 0):" \
+               -e "/nfconntrack=[01]/s:=[01]:=$(usex conntrack 1 0):" \
+               configure || die
+
+       local myeconfargs=(
+               --sbindir="${EPREFIX}/sbin"
+               --libexecdir="${EPREFIX}/$(get_libdir)"
+               --enable-devel
+               --enable-shared
+               $(use_enable nftables)
+               $(use_enable pcap bpf-compiler)
+               $(use_enable pcap nfsynproxy)
+               $(use_enable static-libs static)
+               $(use_enable ipv6)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+       # Deal with parallel build errors.
+       use nftables && emake -C iptables xtables-config-parser.h
+       emake V=1
+}
+
+src_install() {
+       default
+       dodoc INCOMPATIBILITIES iptables/iptables.xslt
+
+       # all the iptables binaries are in /sbin, so might as well
+       # put these small files in with them
+       into /
+       dosbin iptables/iptables-apply
+       dosym iptables-apply /sbin/ip6tables-apply
+       doman iptables/iptables-apply.8
+
+       insinto /usr/include
+       doins include/iptables.h $(use ipv6 && echo include/ip6tables.h)
+       insinto /usr/include/iptables
+       doins include/iptables/internal.h
+
+       keepdir /var/lib/iptables
+       newinitd "${FILESDIR}"/${PN}.init iptables
+       newconfd "${FILESDIR}"/${PN}-1.4.13.confd iptables
+       if use ipv6 ; then
+               keepdir /var/lib/ip6tables
+               newinitd "${FILESDIR}"/iptables.init ip6tables
+               newconfd "${FILESDIR}"/ip6tables-1.4.13.confd ip6tables
+       fi
+
+       if use nftables; then
+               # Bug 647458
+               rm "${ED%/}"/etc/ethertypes || die
+       fi
+
+       systemd_dounit "${FILESDIR}"/systemd/iptables-{re,}store.service
+       if use ipv6 ; then
+               systemd_dounit "${FILESDIR}"/systemd/ip6tables-{re,}store.service
+       fi
+
+       # Move important libs to /lib #332175
+       gen_usr_ldscript -a ip{4,6}tc iptc xtables
+
+       find "${ED}" -name "*.la" -delete || die
+}