dev-vcs/git-flow: Version bump 1.9.1
authorJohannes Huber <johu@gentoo.org>
Fri, 11 Mar 2016 19:51:53 +0000 (20:51 +0100)
committerJohannes Huber <johu@gentoo.org>
Fri, 11 Mar 2016 19:52:08 +0000 (20:52 +0100)
Package-Manager: portage-2.2.28

dev-vcs/git-flow/Manifest
dev-vcs/git-flow/git-flow-1.8.0-r1.ebuild
dev-vcs/git-flow/git-flow-1.8.0-r2.ebuild
dev-vcs/git-flow/git-flow-1.9.1.ebuild [new file with mode: 0644]
dev-vcs/git-flow/metadata.xml

index 3e844ee7f23f5794270da102dbe5dff0e5d3667b..beb86577fdd31949de447511e5d8100bd2723dc5 100644 (file)
@@ -1,2 +1,4 @@
 DIST git-flow-1.8.0.tar.gz 56304 SHA256 8239131b8dac160d7e929eab376fa14de44a55cbd5c5545e0ad4464d3a57adef SHA512 677bfb0c379eb91bfaf8ef676593d39a8306ff063251e1e638166c7101c24ce2eac59490bab85d0c76b712c1905f15d3a14a3ecc020df376848d3b1ea5ee7b0a WHIRLPOOL 6bf654329b941989a8b646ab8218c072b7bf455b0ec6a8441d43de10b9b480a5619bca931606acdd743b0f3f86e9b67f119ff07957eaa106fd17f5cddc96a328
+DIST git-flow-1.9.1.tar.gz 61800 SHA256 7692c77744663c5243cdd390bef0a621caee92dde228b50ef97149fc1b54780d SHA512 6245ff641452e72490b8d12610bc1352048efc2016000b9a6f466140e06c41b05a9fbea8ec192f106bb790b76b56babca8bb684a5128739873d2f7fafe48ad32 WHIRLPOOL 904867ecc1cd7f52dd48b839046df838f019aa9472b6e7202de562b70cac83203e10f0de7359279d619e4391d8ae3019ff9fa797a91d6b7ea0ed132c21ccaa60
 DIST git-flow-completion-0.5.1.tar.gz 6916 SHA256 5c8547a549dc623a8d57cfc22c3fa88588f5630da9dc6de9638e5b69da9d47d0 SHA512 c1fc0000889faff8189cd985b077cb64b81ae13e17f02c9df27675f428c6edf8f00627effdf6ebdae7a7f0641ec4ac621a9ecd0a53f14be7d95ec7e124ab8c1b WHIRLPOOL fd59f799d944752eab06b35f05c1f1309ef589014a0378f292e4dde206578f0c0aeb3685e16ea8d2f810e93b77abb7a2bc42c3c335ef9057b9c3ee1dd6df9982
+DIST git-flow-completion-0.5.2.tar.gz 7501 SHA256 7d11d82b9a3c25f7c7189ac61d21a4edb2432435d6138f092f49348bb17917df SHA512 500cb6163ebb2bf9b996dd5bcac00efa857badfc95ee1d633f2b16803c6baae7315a96c713107645e0971be4736fe1eef747dc773eb50da138551be4838c21b3 WHIRLPOOL 90eaf0d6adcc87369455129052cbcad9c153fe91892a0607fd311bb370a1004b9f85664d0fb06907369bc6bbe6a224a95981fa5d5518610fab2cade0d33c7957
index 3c7de0d0548f19b46947a4322551ad269fc219e5..443bc7dfdc5a3e829420d4550b4201584278bbb1 100644 (file)
@@ -10,7 +10,7 @@ COMP_PV="0.5.1"
 COMP_P="${COMP_PN}-${COMP_PV}"
 inherit eutils bash-completion-r1
 
-DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
+DESCRIPTION="Git extensions to provide high-level repository operations"
 HOMEPAGE="https://github.com/petervanderdoes/gitflow"
 SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
 https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
index 969188df3e9c11dec1c193cc236b967c5630b68c..3446bd2edf5fb1f8609a3a9725a1f851ad4da8a2 100644 (file)
@@ -10,7 +10,7 @@ COMP_PV="0.5.1"
 COMP_P="${COMP_PN}-${COMP_PV}"
 inherit bash-completion-r1
 
-DESCRIPTION="Git extensions to provide high-level repository operations for Vincent Driessen's branching model"
+DESCRIPTION="Git extensions to provide high-level repository operations"
 HOMEPAGE="https://github.com/petervanderdoes/gitflow"
 SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
 https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
diff --git a/dev-vcs/git-flow/git-flow-1.9.1.ebuild b/dev-vcs/git-flow/git-flow-1.9.1.ebuild
new file mode 100644 (file)
index 0000000..c00e12c
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+MY_PN="${PN/-/}-avh"
+COMP_PN="${PN}-completion"
+COMP_PV="0.5.2"
+COMP_P="${COMP_PN}-${COMP_PV}"
+inherit bash-completion-r1
+
+DESCRIPTION="Git extensions to provide high-level repository operations"
+HOMEPAGE="https://github.com/petervanderdoes/gitflow"
+SRC_URI="https://github.com/petervanderdoes/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+https://github.com/petervanderdoes/${COMP_PN}/archive/${COMP_PV}.tar.gz -> ${COMP_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+       dev-vcs/git
+"
+
+DOCS=( AUTHORS Changes.mdown README.mdown )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_compile() {
+       true
+}
+
+src_install() {
+       emake prefix="${D}/usr" install
+       einstalldocs
+       newbashcomp "${WORKDIR}/${COMP_P}/${COMP_PN}.bash" ${PN}
+}
index 705ae330c4e6320440fa9fd3a81284a6c22d32f4..2b1cda651a623960f100678df6c1e2ae5979a03e 100644 (file)
@@ -5,7 +5,11 @@
                <email>johu@gentoo.org</email>
                <name>Johannes Huber</name>
        </maintainer>
+       <longdescription>
+               Git extensions to provide high-level repository operations for Vincent
+               Driessen's branching model.
+       </longdescription>
        <upstream>
-               <remote-id type="github">petervanderdoes/gitflow</remote-id>
+               <remote-id type="github">petervanderdoes/gitflow-avh</remote-id>
        </upstream>
 </pkgmetadata>