dev-python/graphviz: bump to version 0.13
authorConrad Kostecki <conrad@kostecki.com>
Mon, 23 Sep 2019 20:50:32 +0000 (22:50 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 24 Sep 2019 05:00:31 +0000 (08:00 +0300)
Also added python3.7 support and EAPI=7.

Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-python/graphviz/Manifest
dev-python/graphviz/graphviz-0.13.ebuild [new file with mode: 0644]

index 22013e4f9cf1c19ca6b601c5170f251c7808893b..105ada540ecbebb4b9e0f4eecfdf462b8340f717 100644 (file)
@@ -1,2 +1,3 @@
 DIST graphviz-0.10.1.zip 167590 BLAKE2B 4ca344cffe042bd16de56c15ae8056805e7ea82c88b0a9b535cc42d77038d1b54f1f4102630df3b3961e2edf7ab36e2cab75aea6a73a98c603609e0df82ab1fd SHA512 49366190fd3bd703c3d85a9220a63e5a667dc35a41037a54167f3ba96098945b2331294ece4ab260d7006b260cfdd0558b007768fb5f51aededf0b2c0d302eff
+DIST graphviz-0.13.zip 181039 BLAKE2B 6484706c706941891500350c933cad537e63b8f6bd602c46d493ac211842bd9762ff25d7b97c8eda9b8f345e20712971e79afbc099087a8db2fcb3e734591b71 SHA512 3401aeebd6b19f487998aeb4cffcf9598ed31a861b6d335fc76295474512068692371b061a83fb001098010813c0ab61a06c3f2c410c9c9d108000a6b2ab6631
 DIST graphviz-0.7.1.zip 100779 BLAKE2B b981953160f1978fe62b6c2cf422fcde78cc4de80a5274fd6e59c15f8907b34c68b0413d2c538d507d43bd8761349cd7fe532744d2e5ad737f403e52e1fca7b2 SHA512 e8ba326060ff3039f74902c01cf3d96c9965ce2259d0d5a9594e399added05c7e25b0f6c4b0be9ab21c1d37bbfb69e9c4856a7bb457b545185d48838d34cac70
diff --git a/dev-python/graphviz/graphviz-0.13.ebuild b/dev-python/graphviz/graphviz-0.13.ebuild
new file mode 100644 (file)
index 0000000..15f6ec7
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple Python interface for Graphviz"
+HOMEPAGE="https://graphviz.readthedocs.io/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="
+       app-arch/unzip
+       test? ( ${RDEPEND}
+               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+               >=dev-python/pytest-3.4[${PYTHON_USEDEP}]
+               >=dev-python/pytest-mock-1.8[${PYTHON_USEDEP}]
+               dev-python/pytest-cov[${PYTHON_USEDEP}]
+       )
+"
+BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+       py.test -v || die
+}