sys-devel/llvm: Control lit job count
authorMichał Górny <mgorny@gentoo.org>
Thu, 8 Mar 2018 21:58:35 +0000 (22:58 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 8 Mar 2018 22:18:53 +0000 (23:18 +0100)
Closes: https://bugs.gentoo.org/649554

sys-devel/llvm/llvm-6.0.9999.ebuild
sys-devel/llvm/llvm-9999.ebuild

index a0f997bfbd73f81c450e8ecdd07452a55b76b97f..d460300fe422613d5423139d95bbf93c5d5f9ba9 100644 (file)
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
 PYTHON_COMPAT=( python2_7 )
 
 inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
-       pax-utils python-any-r1 toolchain-funcs
+       multiprocessing pax-utils python-any-r1 toolchain-funcs
 
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
@@ -136,7 +136,7 @@ multilib_src_configure() {
 #      fi
 
        use test && mycmakeargs+=(
-               -DLLVM_LIT_ARGS="-vv"
+               -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
        )
 
        if multilib_is_native_abi; then
index 85c7b23b9874ae44805229f4709530deee124e90..ca30a2f3e4fbad10a10879dbc26ca835379fc7e4 100644 (file)
@@ -9,7 +9,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
 PYTHON_COMPAT=( python2_7 )
 
 inherit cmake-utils eapi7-ver flag-o-matic git-r3 multilib-minimal \
-       pax-utils python-any-r1 toolchain-funcs
+       multiprocessing pax-utils python-any-r1 toolchain-funcs
 
 DESCRIPTION="Low Level Virtual Machine"
 HOMEPAGE="https://llvm.org/"
@@ -141,7 +141,7 @@ multilib_src_configure() {
 #      fi
 
        use test && mycmakeargs+=(
-               -DLLVM_LIT_ARGS="-vv"
+               -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
        )
 
        if multilib_is_native_abi; then