dev-python/testresources: Add pypy3 support
authorJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 06:15:21 +0000 (08:15 +0200)
committerJustin Lecher <jlec@gentoo.org>
Mon, 24 Aug 2015 10:12:08 +0000 (12:12 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/testresources/testresources-0.2.7-r2.ebuild

index b4f611fc6a069f3aa8645f4f6a4baae06c92bd75..cb77788f9f899b8588a98268d20459b63481174b 100644 (file)
@@ -3,7 +3,8 @@
 # $Id$
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
 
 inherit distutils-r1
 
@@ -16,10 +17,13 @@ SLOT="0"
 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 x86 ~amd64-linux ~x86-linux"
 IUSE="test"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-               test? ( dev-python/nose[${PYTHON_USEDEP}]
-                               dev-python/testtools[${PYTHON_USEDEP}]
-                               dev-python/fixtures[${PYTHON_USEDEP}] )"
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/testtools[${PYTHON_USEDEP}]
+               dev-python/fixtures[${PYTHON_USEDEP}]
+       )"
 RDEPEND=""
 
 python_test() {