Set the active Python to 2.x since this doesn't build with 3.x
authorDoug Goldstein <cardoe@gentoo.org>
Mon, 24 Oct 2011 18:32:35 +0000 (18:32 +0000)
committerDoug Goldstein <cardoe@gentoo.org>
Mon, 24 Oct 2011 18:32:35 +0000 (18:32 +0000)
Package-Manager: portage-2.1.10.31/cvs/Linux x86_64

sys-apps/seabios/ChangeLog
sys-apps/seabios/Manifest
sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild

index 5efb9d4b3bd633191d09f1c6b7c03e099c9dd0cd..202576ef728ae0335b342714f5dcbc4645388002 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-apps/seabios
 # Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.3 2011/10/21 16:55:20 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/ChangeLog,v 1.4 2011/10/24 18:32:35 cardoe Exp $
+
+  24 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
+  seabios-0.6.3_pre20010817.ebuild:
+  Set the active Python to 2.x since this doesn't build with 3.x
 
   21 Oct 2011; Doug Goldstein <cardoe@gentoo.org>
   seabios-0.6.3_pre20010817.ebuild:
index f347cd1bb5f16ceecf83bd4cf1a098864433ec76..d920715ef36c41dc0911e31e11dc091e1c48e297 100644 (file)
@@ -1,3 +1,3 @@
-EBUILD seabios-0.6.3_pre20010817.ebuild 1312 RMD160 7a2a3eeca7c94d20595949757260b0f8d03248e4 SHA1 c46adbddb16aefda662a0ab44187f6a3ee84efa6 SHA256 d925a38bf4b32fa5de2507ae77cbd6aa4544d49f3e76cb5ad4f44642f10ae7d1
-MISC ChangeLog 673 RMD160 8a7e6170acb63c2a80bf398ae62cfb4b59308417 SHA1 2c4f4b90fc487f77472e75c3c7d3362e34d70a77 SHA256 1aabdbff29f7cda36b7b0d874cbbb4f9e027a657124b92044c521957c178a12f
+EBUILD seabios-0.6.3_pre20010817.ebuild 1365 RMD160 b813871bd6a40336d4b9543d1843e0c0e10f8457 SHA1 ec70e44a86c9d97a160cd64c865a48e316c30468 SHA256 8e155db378ea6bf37b4972e4c2e0980f59868caf1a89291afd978c091f15adb5
+MISC ChangeLog 825 RMD160 1badc2b8c75f608f70dbf121b4a6652437ad3507 SHA1 06e94a8cf05655a446bd4941565edf53242473bd SHA256 87269f1e9249428d217f8f56942f5b6b0388d12221bae3e91b128e90934c11c8
 MISC metadata.xml 263 RMD160 dfb6b4419fbd63abc11c8a94537cfc2ec9f2b443 SHA1 a14bd41b62c7b296d63ff53cb3f31b395ea56975 SHA256 15b7a062b1daa951b969cfac555896a705973335aeab1b9567c0a413501024d6
index 765d63f294dee79183acba80d6d69764a89ab01e..fa38ea82c8931e0d43ec153accc0715010bf8cb8 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2011 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild,v 1.5 2011/10/21 16:55:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/seabios/seabios-0.6.3_pre20010817.ebuild,v 1.6 2011/10/24 18:32:35 cardoe Exp $
 
 EAPI=4
 
@@ -16,7 +16,7 @@ else
        ${BACKPORTS:+http://dev.gentoo.org/~cardoe/distfiles/${P}-bp-${BACKPORTS}.tar.bz2}"
 fi
 
-inherit ${GIT_ECLASS}
+inherit ${GIT_ECLASS} python
 
 if [[ ${PV} = *9999* ]]; then
        KEYWORDS=""
@@ -36,6 +36,10 @@ RDEPEND="${DEPEND}
        !app-emulation/qemu
        !<=app-emulation/qemu-kvm-0.15.0"
 
+pkg_setup() {
+       python_set_active_version 2
+}
+
 src_prepare() {
        if [[ -z "${EGIT_COMMIT}" ]]; then
                sed -e "s/VERSION=.*/VERSION=${PV}/" \