projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
16c8f0d
)
media-gfx/inkscape-1.0_beta1: improved extensions check
author
Miroslav Šulc
<fordfrog@gentoo.org>
Thu, 7 Nov 2019 15:54:37 +0000
(16:54 +0100)
committer
Miroslav Šulc
<fordfrog@gentoo.org>
Thu, 7 Nov 2019 15:54:52 +0000
(16:54 +0100)
Bug: https://bugs.gentoo.org/696794
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
media-gfx/inkscape/inkscape-1.0_beta1.ebuild
patch
|
blob
|
history
diff --git
a/media-gfx/inkscape/inkscape-1.0_beta1.ebuild
b/media-gfx/inkscape/inkscape-1.0_beta1.ebuild
index 578f4ed7dfcd43d2844674efe62fe6c2b7b49187..3bed12295c66221b57eb3b6911fe0d71643d4c34 100644
(file)
--- a/
media-gfx/inkscape/inkscape-1.0_beta1.ebuild
+++ b/
media-gfx/inkscape/inkscape-1.0_beta1.ebuild
@@
-150,7
+150,9
@@
src_install() {
find "${ED}" -type f -name "*.la" -delete || die
# No extensions are present in beta1
- if [[ -n $(find "${ED}"/usr/share/${PN}/extensions -mindepth 1) ]]; then
+ local extdir="${ED}"/usr/share/${PN}/extensions
+
+ if [[ -e "${extdir}" ]] && [[ -n $(find "${extdir}" -mindepth 1) ]]; then
python_optimize "${ED}"/usr/share/${PN}/extensions
fi