net-misc/unison: Replace STRIP_MASK with RESTRICT=strip
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Apr 2019 08:12:00 +0000 (10:12 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 5 Jul 2019 20:17:01 +0000 (22:17 +0200)
Closes: https://bugs.gentoo.org/651454
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-misc/unison/unison-2.48.4-r1.ebuild
net-misc/unison/unison-2.48.4.ebuild
net-misc/unison/unison-2.51.2.ebuild

index 55e5485844d4a4438ffef0ba2eab7213a9898e30..01f53f133dfd1756850e7de084dd4c84169a41fa 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -25,6 +25,7 @@ RDEPEND="gtk? ( dev-ml/lablgtk
        || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
        >=app-eselect/eselect-unison-0.4"
 
+RESTRICT="!ocamlopt? ( strip )"
 SRC_URI="https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
        doc? ( https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
                https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
@@ -76,7 +77,6 @@ src_install () {
                HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
        fi
        einstalldocs
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }
 
 pkg_postinst() {
index 1fec2677b4ed941292803b447bfe039b2671aa1d..1cbadbf207acbbc79038351ba6222e1cb0c8e7c6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
@@ -25,6 +25,7 @@ RDEPEND="gtk? ( dev-ml/lablgtk
 
 #PDEPEND="gtk? ( media-fonts/font-schumacher-misc )"
 
+RESTRICT="!ocamlopt? ( strip )"
 SRC_URI="https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}.tar.gz
        doc? ( https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.pdf
                https://www.seas.upenn.edu/~bcpierce/unison/download/releases/${P}/${P}-manual.html )"
@@ -78,7 +79,6 @@ src_install () {
                dohtml "${DISTDIR}/${P}-manual.html"
                dodoc "${DISTDIR}/${P}-manual.pdf"
        fi
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }
 
 pkg_postinst() {
index 25776c6fb519fc5d23fea15f2cde79de15e0e956..af6cf20473a2cd21ca0995d96600dd2c3e04da63 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -24,6 +24,7 @@ RDEPEND="gtk? ( dev-ml/lablgtk
        || ( net-misc/x11-ssh-askpass net-misc/ssh-askpass-fullscreen ) )
        >=app-eselect/eselect-unison-0.4"
 
+RESTRICT="!ocamlopt? ( strip )"
 S="${WORKDIR}"/src
 
 DOCS=( BUGS.txt CONTRIB INSTALL NEWS README ROADMAP.txt TODO.txt )
@@ -71,7 +72,6 @@ src_install () {
                HTML_DOCS=( "${DISTDIR}/${P}-manual.html" )
        fi
        einstalldocs
-       use ocamlopt || export STRIP_MASK="*/bin/*"
 }
 
 pkg_postinst() {