Fix sed expression. (bug #160326)
authorDavid Shakaryan <omp@gentoo.org>
Wed, 17 Jan 2007 00:17:42 +0000 (00:17 +0000)
committerDavid Shakaryan <omp@gentoo.org>
Wed, 17 Jan 2007 00:17:42 +0000 (00:17 +0000)
Package-Manager: portage-2.1.2

sys-libs/libixp/ChangeLog
sys-libs/libixp/libixp-0.2-r1.ebuild

index 15bd5d083a9215b89d4a9cd6bab082c606746821..dcff239ef05eaca4e7661a6580a1fca0023962e8 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for sys-libs/libixp
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/ChangeLog,v 1.2 2007/01/10 01:18:27 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/ChangeLog,v 1.3 2007/01/17 00:17:42 omp Exp $
+
+  17 Jan 2007; David Shakaryan <omp@gentoo.org> -libixp-0.2.ebuild,
+  libixp-0.2-r1.ebuild:
+  Fix sed expression. (bug #160326)
 
   10 Jan 2007; David Shakaryan <omp@gentoo.org>
   +files/libixp-0.2-shared-object.patch, +libixp-0.2-r1.ebuild:
index ad9d579aa2d10063a5f50c9b7e1ebb8239134672..0034308dee32798638145c65d45fcd0d378cf624 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/libixp-0.2-r1.ebuild,v 1.2 2007/01/10 01:24:29 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libixp/libixp-0.2-r1.ebuild,v 1.3 2007/01/17 00:17:42 omp Exp $
 
 inherit toolchain-funcs
 
@@ -23,12 +23,12 @@ src_unpack() {
        epatch "${FILESDIR}/libixp-0.2-shared-object.patch"
 
        sed -i \
-               -e "/^PREFIX/s/=.*/= \/usr/" \
-               -e "/^CFLAGS/s/= -Os/+=/" \
-               -e "/^LDFLAGS/s/=/+=/" \
-               -e "/^AR/s/=.*/= $(tc-getAR) cr/" \
-               -e "/^CC/s/=.*/= $(tc-getCC)/" \
-               -e "/^RANLIB/s/=.*/= $(tc-getRANLIB)/" \
+               -e "/^PREFIX/s|=.*|= /usr|" \
+               -e "/^CFLAGS/s|= -Os|+=|" \
+               -e "/^LDFLAGS/s|=|+=|" \
+               -e "/^AR/s|=.*|= $(tc-getAR) cr|" \
+               -e "/^CC/s|=.*|= $(tc-getCC)|" \
+               -e "/^RANLIB/s|=.*|= $(tc-getRANLIB)|" \
                config.mk || die "sed failed"
 }