dev-python/pytest-fixture-config: Block py2 pytest-virtualenv
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 19:49:13 +0000 (21:49 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 20:03:37 +0000 (22:03 +0200)
Since dev-python/pytest normally loads all plugins, and PMs don't
necessarily enforce dependencies of these that are not part of @world,
it is possible to break their depgraph and break pytest on py2.7
completely.  Add a blocker to make that harder.

Closes: https://bugs.gentoo.org/720828
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild

index 123812aa6d13f86f9ee1911e42bdba21f1bd30d9..83b350fe07a329e23b2f7c22016774727dac4fb7 100644 (file)
@@ -17,6 +17,10 @@ KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ~ppc ppc64 ~s390 sparc x86"
 RDEPEND="
        dev-python/pytest[${PYTHON_USEDEP}]
 "
+# block pytest plugins that will be broken by the upgrade
+RDEPEND+="
+       !<dev-python/pytest-virtualenv-1.7.0-r1[python_targets_python2_7(-)]
+"
 BDEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/setuptools-git[${PYTHON_USEDEP}]