dev-ml/ocaml-conduit: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 08:18:28 +0000 (09:18 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:49 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/ocaml-conduit/Manifest [new file with mode: 0644]
dev-ml/ocaml-conduit/metadata.xml [new file with mode: 0644]
dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ocaml-conduit/Manifest b/dev-ml/ocaml-conduit/Manifest
new file mode 100644 (file)
index 0000000..56c7c8e
--- /dev/null
@@ -0,0 +1 @@
+DIST ocaml-conduit-0.14.5.tar.gz 38471 SHA256 00aba333c05866bb712f7890c6f9fd457b85cf592d28adc6636413032683f86f SHA512 c2de6518588e3555cd40dfc6c1ce6d809dc570ddb6a07fb8ccce1797469e9c28ea1a633d4a1b360bf15cdb95e6231ecb0be8bd44e4654baa5268f09519096b52 WHIRLPOOL 5e052d7b9d34d76662496739a6934bf64c1930ca64b2160aa8cbefe0237bd0bb3438a187c3dd05d841b7b475325afcb32bb6fb20e0b61b885c16f4b0b3259aea
diff --git a/dev-ml/ocaml-conduit/metadata.xml b/dev-ml/ocaml-conduit/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild b/dev-ml/ocaml-conduit/ocaml-conduit-0.14.5.ebuild
new file mode 100644 (file)
index 0000000..6402be1
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Dereference URIs into communication channels for Async or Lwt"
+HOMEPAGE="https://github.com/mirage/ocaml-conduit"
+SRC_URI="https://github.com/mirage/ocaml-conduit/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-lang/ocaml:=
+       dev-ml/sexplib:=
+       dev-ml/stringext:=
+       dev-ml/ocaml-uri:=
+       dev-ml/logs:=
+       dev-ml/ocaml-cstruct:=
+       dev-ml/ocaml-ipaddr:=
+
+       dev-ml/lwt:=
+       dev-ml/async:=
+       dev-ml/ocaml-dns:=
+       dev-ml/ocaml-ssl:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+       dev-ml/findlib
+       dev-ml/ocamlbuild
+       dev-ml/ppx_driver
+       dev-ml/ppx_optcomp
+       dev-ml/ppx_sexp_conv
+"
+
+DOCS=( TODO.md README.md CHANGES )
+
+src_install() {
+       findlib_src_preinst
+       default
+}