net-wireless/irda-utils: fix bad sed delimiter
authorBen Kohler <bkohler@gentoo.org>
Tue, 24 Mar 2020 13:12:47 +0000 (08:12 -0500)
committerBen Kohler <bkohler@gentoo.org>
Tue, 24 Mar 2020 13:31:45 +0000 (08:31 -0500)
Closes: https://bugs.gentoo.org/710700
Package-Manager: Portage-2.3.95, Repoman-2.3.21
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
net-wireless/irda-utils/irda-utils-0.9.18-r6.ebuild

index 306110bc82c0ac449e25ba268f2fd8ae6783c844..8c24b6ba5ad89dabafeaa237d7e5665c32215fb5 100644 (file)
@@ -53,7 +53,7 @@ src_prepare() {
                -e "/^LD/s:ld:$(tc-getLD):" \
                -e "/^AR/s:ar:$(tc-getAR):" \
                -e "/^RANLIB/s:ranlib:$(tc-getRANLIB):" \
-               -e "/^CFLAGS/s:-O2:${CFLAGS}:" Makefile */Makefile || die
+               -e "/^CFLAGS/s|-O2|${CFLAGS}|" Makefile */Makefile || die
 
        # fix compile when pciutils is compiled with USE=zlib (Bug 200295)
        sed -i -e "s:-lpci:$(pkg-config --libs libpci):g" smcinit/Makefile || die