New point release of dbus 1
authorStephen Klimaszewski <steev@gentoo.org>
Fri, 17 Nov 2006 23:43:48 +0000 (23:43 +0000)
committerStephen Klimaszewski <steev@gentoo.org>
Fri, 17 Nov 2006 23:43:48 +0000 (23:43 +0000)
Package-Manager: portage-2.1.1-r1

sys-apps/dbus/ChangeLog
sys-apps/dbus/dbus-1.0.1.ebuild [new file with mode: 0644]
sys-apps/dbus/files/digest-dbus-1.0.1 [new file with mode: 0644]

index ae8feb3e0e69da05df81b2a6f85c4673246d096e..908337faeff8e285db6d642fc919fb7daea17e2c 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for sys-apps/dbus
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.150 2006/11/17 00:31:43 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/ChangeLog,v 1.151 2006/11/17 23:43:48 steev Exp $
+
+*dbus-1.0.1 (17 Nov 2006)
+
+  17 Nov 2006; Steev Klimaszewski <steev@gentoo.org> -dbus-1.0.0.ebuild,
+  +dbus-1.0.1.ebuild:
+  New point release of D-Bus. Fixes an issue with dbus_threads_init_default
+  asserting when called. It also cleans up the uuid documentation and makes
+  uuid's conform to the spec.
 
   17 Nov 2006; Andrej Kacian <ticho@gentoo.org> dbus-0.62-r1.ebuild:
   Stable on x86, bug #154522.
diff --git a/sys-apps/dbus/dbus-1.0.1.ebuild b/sys-apps/dbus/dbus-1.0.1.ebuild
new file mode 100644 (file)
index 0000000..4f4fce9
--- /dev/null
@@ -0,0 +1,108 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.0.1.ebuild,v 1.1 2006/11/17 23:43:48 steev Exp $
+
+WANT_AUTOCONF=2.5
+inherit eutils multilib debug autotools
+
+DESCRIPTION="A message bus system, a simple way for applications to talk to each other"
+HOMEPAGE="http://dbus.freedesktop.org/"
+SRC_URI="http://dbus.freedesktop.org/releases/dbus/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 AFL-2.1 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux X"
+
+RDEPEND="X? ( x11-libs/libXt x11-libs/libX11 )
+       selinux? ( sys-libs/libselinux )
+       >=dev-libs/expat-1.95.8
+       !<sys-apps/dbus-0.91"
+
+DEPEND="${RDEPEND}
+       dev-util/pkgconfig
+       doc? (  app-doc/doxygen
+               app-text/xmlto )"
+
+src_compile() {
+       local myconf=""
+
+       hasq test ${FEATURES} && myconf="${myconf} --enable-tests=yes"
+
+       econf \
+               $(use_with X x) \
+               $(use_enable kernel_linux dnotify) \
+               $(use_enable kernel_FreeBSD kqueue) \
+               $(use_enable selinux) \
+               $(use_enable debug verbose-mode) \
+               $(use_enable debug asserts) \
+               --with-xml=expat \
+               --with-system-pid-file=/var/run/dbus.pid \
+               --with-system-socket=/var/run/dbus/system_bus_socket \
+               --with-session-socket-dir=/tmp \
+               --with-dbus-user=messagebus \
+               --localstatedir=/var \
+               $(use_enable doc doxygen-docs) \
+               --disable-xml-docs \
+               ${myconf} \
+               || die "econf failed"
+
+       # after the compile, it uses a selinuxfs interface to
+       # check if the SELinux policy has the right support
+       use selinux && addwrite /selinux/access
+
+       emake || die "make failed"
+}
+
+src_test() {
+       DBUS_VERBOSE=1 make check || die "make check failed"
+}
+
+src_install() {
+       make DESTDIR="${D}" install || die "make install failed"
+
+       # initscript
+       newinitd "${FILESDIR}"/dbus.init-0.95 dbus
+
+       # dbus X session script (#77504)
+       # turns out to only work for GDM. has been merged into other desktop
+       # (kdm and such scripts)
+       exeinto /etc/X11/xinit/xinitrc.d/
+       doexe "${FILESDIR}"/30-dbus
+
+       # needs to exist for the system socket
+       keepdir /var/run/dbus
+       # needs to exist for machine id
+       keepdir /var/lib/dbus
+
+       keepdir /usr/lib/dbus-1.0/services
+       keepdir /usr/share/dbus-1/services
+
+       dodoc AUTHORS ChangeLog HACKING NEWS README doc/TODO
+       if use doc; then
+               dohtml doc/*html
+       fi
+}
+
+pkg_preinst() {
+       enewgroup messagebus || die "Problem adding messagebus group"
+       enewuser messagebus -1 "-1" -1 messagebus || die "Problem adding messagebus user"
+}
+
+pkg_postinst() {
+       elog "To start the D-Bus system-wide messagebus by default"
+       elog "you should add it to the default runlevel :"
+       elog "\`rc-update add dbus default\`"
+       elog
+       elog "If dbus is already installed and running,"
+       elog "run etc-update and then run the following:"
+       elog "\`/etc/init.d/dbus reload\`"
+       elog "This will cause it to reload it's configs but"
+       elog "*not* run the newest version you just installed."
+       elog "You must tell it to restart for that to happen,"
+       elog "however not all apps can handle a D-Bus restart."
+       elog
+       ewarn
+       ewarn "You MUST run 'revdep-rebuild' after emerging this package"
+       ewarn
+}
diff --git a/sys-apps/dbus/files/digest-dbus-1.0.1 b/sys-apps/dbus/files/digest-dbus-1.0.1
new file mode 100644 (file)
index 0000000..7660510
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 52c70d18fe0b398f5de3b8a18a589960 dbus-1.0.1.tar.gz 1406595
+RMD160 2270f27d9314f0e7b99540f0aa1902b8d0d7343d dbus-1.0.1.tar.gz 1406595
+SHA256 6e0730a39485fb502d640841f0f328c1a0212743f17b3fa61c78e6e32925f061 dbus-1.0.1.tar.gz 1406595