BUG fix
authorMichael Cummings <mcummings@gentoo.org>
Wed, 31 Dec 2003 14:00:23 +0000 (14:00 +0000)
committerMichael Cummings <mcummings@gentoo.org>
Wed, 31 Dec 2003 14:00:23 +0000 (14:00 +0000)
net-analyzer/rrdtool/ChangeLog
net-analyzer/rrdtool/Manifest
net-analyzer/rrdtool/files/digest-rrdtool-1.0.45-r2 [new file with mode: 0644]
net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild [new file with mode: 0644]

index 5202866f1e1c70103c28d542e7ebc01f77268aaa..f897312757f0ba75051f88a601e7184d9d4111a7 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for net-analyzer/rrdtool
 # Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.26 2003/12/22 23:43:48 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.27 2003/12/31 14:00:16 mcummings Exp $
+
+*rrdtool-1.0.45-r2 (31 Dec 2003)
+
+  31 Dec 2003; Michael Cummings,,, <mcummings@gentoo.org>
+  rrdtool-1.0.45-r2.ebuild:
+  Corrections for the inclusion and operation of the perl portion. There were
+  sandbox violations for the perl man pages becasue of makemaker versions. The
+  new version will cleanly install all parts in all the right places. Bug was
+  reported on IRC by Geert Hauwaerts <geert@irssi.org>
 
 *rrdtool-1.0.45-r1 (22 Dec 2003)
 
index 2eaefe179d7457550f1bf6a84bf625b728a1b8dd..3a8abd1adbbe9533ca15044481e95a78da343427 100644 (file)
@@ -1,9 +1,11 @@
-MD5 6208cb65d1918638aa255492594b314c rrdtool-1.0.42-r1.ebuild 2281
-MD5 4988b6d00ac229765252cdcda097c09b rrdtool-1.0.45-r1.ebuild 2342
+MD5 29176c8bab95d2bf18ad439c25f1dc32 ChangeLog 5095
 MD5 a34a3c9dd7c05f7fa28ed0521268bc5c rrdtool-1.0.45.ebuild 2325
 MD5 ea6990f6fcf8781ccb96cfddade41f85 rrdtool-1.0.40-r1.ebuild 2220
-MD5 6568b7a43b73f2daa2c38401def844b5 ChangeLog 4678
+MD5 6208cb65d1918638aa255492594b314c rrdtool-1.0.42-r1.ebuild 2281
+MD5 bd2e5a436d2d75cd6eba9e4fdedee325 rrdtool-1.0.45-r2.ebuild 2675
+MD5 4988b6d00ac229765252cdcda097c09b rrdtool-1.0.45-r1.ebuild 2342
 MD5 dd9238326165d64f1c400c9e38cfda28 files/digest-rrdtool-1.0.45 67
 MD5 97610425876ad7e680316d1a3e808c4b files/digest-rrdtool-1.0.40-r1 67
 MD5 e2341044ceaf46443ec4c577647d9cae files/digest-rrdtool-1.0.42-r1 67
 MD5 dd9238326165d64f1c400c9e38cfda28 files/digest-rrdtool-1.0.45-r1 67
+MD5 dd9238326165d64f1c400c9e38cfda28 files/digest-rrdtool-1.0.45-r2 67
diff --git a/net-analyzer/rrdtool/files/digest-rrdtool-1.0.45-r2 b/net-analyzer/rrdtool/files/digest-rrdtool-1.0.45-r2
new file mode 100644 (file)
index 0000000..4a703fa
--- /dev/null
@@ -0,0 +1 @@
+MD5 64086fc7f1ca28c069ee5104f85d7a8c rrdtool-1.0.45.tar.gz 1176656
diff --git a/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild b/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild
new file mode 100644 (file)
index 0000000..386e678
--- /dev/null
@@ -0,0 +1,121 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.0.45-r2.ebuild,v 1.1 2003/12/31 14:00:16 mcummings Exp $
+
+inherit perl-module flag-o-matic gnuconfig
+
+DESCRIPTION="A system to store and display time-series data"
+SRC_URI="http://people.ee.ethz.ch/%7Eoetiker/webtools/${PN}/pub/${P}.tar.gz"
+HOMEPAGE="http://people.ee.ethz.ch/~oetiker/webtools/rrdtool/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc ~sparc ~amd64 ~alpha"
+IUSE="tcltk perl"
+
+filter-mfpmath "sse"
+filter-flags "-ffast-math"
+
+DEPEND="perl? ( dev-lang/perl )
+       sys-apps/gawk
+       >=media-libs/libgd-1.8.3"
+RDEPEND="tcltk? ( dev-lang/tcl )"
+TCLVER=""
+
+pkg_setup() {
+       if [ "`use tcltk`" ]; then
+               TCLVER=`awk -F\' '/TCL_VERSION/ {print $2}' /usr/lib/tclConfig.sh`
+       fi
+
+       if [ "`use perl`" ]; then
+               perl-module_pkg_setup
+       fi
+}
+
+src_compile() {
+       local myconf
+       use tcltk \
+               && myconf="${myconf} --with-tcllib=/usr/lib" \
+               || myconf="${myconf} --without-tcllib"
+
+       use amd64 && gnuconfig_update
+
+       if [ `use perl` ] ; then
+       MMSIXELEVEN=`perl -e 'use ExtUtils::MakeMaker; print( $ExtUtils::MakeMaker::VERSION ge "6.11" )'`
+         if [ "${MMSIXELEVEN}" ]; then
+          econf \
+               --datadir=/usr/share \
+               --enable-shared \
+               --with-perl-options='INSTALLDIRS=vendor destdir=${D}/' \
+               ${myconf} || die
+
+         else
+          econf \
+               --datadir=/usr/share \
+               --enable-shared \
+               --with-perl-options='PREFIX=${D}/usr INSTALLDIRS=vendor' \
+               ${myconf} || die
+         fi
+       else
+        econf \
+         --datadir=/usr/share \
+         --enable-shared \
+         ${myconf} || die
+       fi
+
+       make || die
+}
+
+src_install() {
+       einstall || die
+
+       # this package completely ignores mandir settings
+
+       doman doc/*.1
+       dohtml doc/*.html
+       dodoc doc/*.pod
+       dodoc doc/*.txt
+
+       rm -rf ${D}/usr/doc
+       rm -rf ${D}/usr/html
+       rm -rf ${D}/usr/man
+       rm -rf ${D}/usr/contrib
+       rm -rf ${D}/usr/examples
+
+       insinto /usr/share/doc/${PF}/examples
+       doins examples/*
+       insinto /usr/share/doc/${PF}/contrib
+       doins contrib/*
+
+       if [ `use perl` ] ; then
+               perlinfo
+               mytargets="site-perl-install"
+               perl-module_src_install || die
+       fi
+
+       if [ `use tcltk` ] ; then
+               mv ${S}/tcl/tclrrd.so ${S}/tcl/tclrrd${PV}.so
+               insinto /usr/lib/tcl${TCL_VER}/tclrrd${PV}
+               doins ${S}/tcl/tclrrd${PV}.so
+               echo "package ifneeded Rrd ${PV} [list load [file join \$$dir .. tclrrd${PV}.so]]" \
+                       >> ${D}/usr/lib/tcl${TCL_VER}/tclrrd${PV}/pkgIndex.tcl
+       fi
+
+       dodoc COPY* CONTR* README TODO
+}
+
+pkg_preinst() {
+       use perl && perl-module_pkg_preinst
+}
+
+pkg_postinst() {
+       use perl && perl-module_pkg_postinst
+}
+
+pkg_prerm() {
+       use perl && perl-module_pkg_prerm
+}
+
+pkg_postrm() {
+       use perl && perl-module_pkg_postrm
+}