app-text/tidy-html5: version bump.
authorPatrice Clement <monsieurp@gentoo.org>
Tue, 14 Mar 2017 22:46:55 +0000 (23:46 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Tue, 14 Mar 2017 23:45:57 +0000 (00:45 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-text/tidy-html5/Manifest
app-text/tidy-html5/tidy-html5-5.4.0.ebuild [new file with mode: 0644]

index 950d96c8ae804e89376d626e8fd16e6002a27036..7561ff6e05fc0a97cc330fd21c910a4a974354a9 100644 (file)
@@ -1 +1,2 @@
 DIST tidy-html5-5.2.0.zip 578494 SHA256 7f6ef14e41a0e9611fcb95e4926287e0d4a46c53335ae7e3aa4fc11ae69d32e2 SHA512 0559bbe24711606b391057b3dbf2692b54e548294f68b310be306b5be80c9265ba7c4aa8da2b13ba0c89dae1dd6d233aebebdba761e25193439a0c0d713e59d8 WHIRLPOOL 7040ad176d2a96936cf250afc16f8376c9febd80ef98976bca318407299e52896c34a23964654efb1d69a2bf49438f6402d4af9d140ce45f6fe7d27bda010dce
+DIST tidy-html5-5.4.0.zip 573217 SHA256 aa9d611cdee60ef0d20941f6c5f09240189e3a90e4ef8994b15bf561ce3ed691 SHA512 788646c0c15a1be58695469977c340cbe7d37fada63faea34b67c1d7ffe6074ed2b6dcd6cc946a0ae99cd5319c9a8c5ffb81958f82b6097a35a3215bc1776fa8 WHIRLPOOL f081b17b22feb05c436756dea7e55cdd98608bc99d085db0121e0fdb297761dc7a87b4793586cdaf841bcc4a6bd1e08a566620030702482bd1ecce7dcdd94c86
diff --git a/app-text/tidy-html5/tidy-html5-5.4.0.ebuild b/app-text/tidy-html5/tidy-html5-5.4.0.ebuild
new file mode 100644 (file)
index 0000000..4632b3e
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="http://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+
+RDEPEND="!app-text/htmltidy"
+
+DOCS=( README/{CODESTYLE,CONTRIBUTING,LICENSE,VERSION}.md )
+
+BUILD_DIR="${S}/build/cmake"
+
+src_configure() {
+       local mycmakeargs=(
+               -DCMAKE_INSTALL_PREFIX=/usr
+               -DCMAKE_BUILD_TYPE=Release
+       )
+
+       cmake-utils_src_configure
+}
+
+src_compile() {
+       cd build/cmake || die
+       cmake-utils_src_compile
+}
+
+src_install() {
+       cmake-utils_src_install
+}