change "cvs diff -fU 0" => "cvs -f diff U0" because -f is a global option, not a...
authoragriffis <agriffis@gentoo.org>
Tue, 9 Nov 2004 14:34:21 +0000 (14:34 -0000)
committeragriffis <agriffis@gentoo.org>
Tue, 9 Nov 2004 14:34:21 +0000 (14:34 -0000)
svn path=/; revision=168

trunk/src/echangelog/ChangeLog
trunk/src/echangelog/echangelog

index 059d93701d2c819cb38098a9cb408b9863cbe109..26ea9b42e60d2cf8c907f1e3123c5f589a0fa29b 100644 (file)
@@ -1,3 +1,7 @@
+09 Nov 2004 Aron Griffis <agriffis@gentoo.org>
+       * change "cvs diff -fU 0" => "cvs -f diff U0" because -f is a
+         global option, not a diff option
+
 08 Nov 2004 Aron Griffis <agriffis@gentoo.org>
        * call cvs with -f to refrain from using .cvsrc, which might
          contain conflicting options
index 65b2eddf50f2b5393935e4c4736786f4e2341812..01b77f4065ccb00395ecb1d3f47ac36248a31664 100644 (file)
@@ -53,6 +53,7 @@ if (-f 'ChangeLog') {
 # Figure out what has changed around here
 open C, 'cvs -fn up 2>&1 |' or die "Can't run cvs -fn up: $!\n";
 while (<C>) {
+    #print STDERR "cvs: $_";
     /ChangeLog/ and next;
     /^\? (\S+)/ and push @unknown, $1;
     /^([ARMC]) (\S+)/ or next;
@@ -72,10 +73,13 @@ EOT
 # the changed files we have
 @ebuilds = grep /\.ebuild$/, @files;
 @files = grep !/\.ebuild$/, @files;
+#print STDERR '@ebuilds = [', join('],[', @ebuilds), "]\n";
+#print STDERR '@files = [', join('],[', @files), "]\n";
 if (@ebuilds) {
-    open C, "cvs diff -fU 0 @ebuilds 2>&1 |" or die "Can't run cvs diff: $!\n";
+    open C, "cvs -f diff -U0 @ebuilds 2>&1 |" or die "Can't run cvs diff: $!\n";
     $_ = <C>;
     while (defined $_) {
+        #print STDERR "cvs: $_";
         if (/^cvs diff: (([^\/]*?)\.ebuild) was removed/) { 
             push @files, $1;
             $versions{$2} = 0; # existing ebuild that was removed