media-gfx/comix: Remove last-rited package
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 21:47:07 +0000 (22:47 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 22 Mar 2020 23:06:21 +0000 (00:06 +0100)
Closes: https://bugs.gentoo.org/708100
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/comix/Manifest [deleted file]
media-gfx/comix/comix-4.0.4-r2.ebuild [deleted file]
media-gfx/comix/files/comix-4.0.4-pillow.patch [deleted file]
media-gfx/comix/metadata.xml [deleted file]
profiles/package.mask

diff --git a/media-gfx/comix/Manifest b/media-gfx/comix/Manifest
deleted file mode 100644 (file)
index 7c94d1e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST comix-4.0.4.tar.gz 481687 BLAKE2B adf73f63d260fa4171f4e85fe74e25e52253ea4c78eb3d2be8d9319ddeef537899415a582b8f33db76a8e30acf77c2d5bd1fc5b931302040d967bdd39b45e9ff SHA512 9cbc5b1cc100ee50b48b794ce9a7f08130fc7a79376533f0f55904be0e2e8cfe5f8b1deeff2f76e7038a3f81b0f709ce5eea88a709199e1584b73f5259df5f8e
diff --git a/media-gfx/comix/comix-4.0.4-r2.ebuild b/media-gfx/comix/comix-4.0.4-r2.ebuild
deleted file mode 100644 (file)
index fa7c18e..0000000
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-PLOCALES="ca cs es fr hr hu id ja ko pl pt_BR ru sv zh_CN zh_TW"
-
-inherit eutils gnome2-utils l10n python-single-r1 xdg-utils
-
-DESCRIPTION="A GTK image viewer specifically designed to handle comic books"
-HOMEPAGE="http://comix.sourceforge.net"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="rar"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
-       $(python_gen_cond_dep '
-               dev-python/pillow[${PYTHON_MULTI_USEDEP}]
-               >=dev-python/pygtk-2.12[${PYTHON_MULTI_USEDEP}]
-       ')"
-RDEPEND="${DEPEND}
-       rar? ( || ( app-arch/unrar app-arch/rar ) )"
-
-pkg_setup() {
-       python-single-r1_pkg_setup
-}
-
-src_prepare() {
-       l10n_find_plocales_changes messages "" "/LC_MESSAGES/comix.po"
-
-       epatch "${FILESDIR}/${P}-pillow.patch" #471522, https://sourceforge.net/p/comix/patches/50/
-
-       # do not install .pyc into /usr/share
-       local pythondir="$(python_get_sitedir)/comix"
-       pythondir="${pythondir#${EPREFIX}/usr/}"
-       sed -i -e "s:share/comix/src:${pythondir}:g" install.py || die
-       python_fix_shebang mime/comicthumb src/comix.py
-}
-
-src_install() {
-       dodir /usr
-       "${PYTHON}" install.py install --no-mime --dir "${D}"usr || die
-
-       insinto /usr/share/mime/packages
-       doins mime/comix.xml
-
-       insinto /etc/gconf/schemas
-       doins mime/comicbook.schemas
-
-       dobin mime/comicthumb
-       dodoc ChangeLog README
-
-       remove_locale() {
-               rm -r "${ED}/usr/share/locale/"$1 || die
-       }
-       l10n_for_each_disabled_locale_do remove_locale
-}
-
-pkg_preinst() {
-       gnome2_gconf_savelist
-       gnome2_icon_savelist
-}
-
-pkg_postinst() {
-       gnome2_gconf_install
-       xdg_desktop_database_update
-       xdg_mimeinfo_database_update
-       gnome2_icon_cache_update
-}
-
-pkg_postrm() {
-       xdg_desktop_database_update
-       xdg_mimeinfo_database_update
-       gnome2_icon_cache_update
-}
diff --git a/media-gfx/comix/files/comix-4.0.4-pillow.patch b/media-gfx/comix/files/comix-4.0.4-pillow.patch
deleted file mode 100644 (file)
index f91bfcd..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-From 9d31aa97c8bcc7828e6d04ec4375a75a9bf06836 Mon Sep 17 00:00:00 2001
-From: Alexandre Rostovtsev <tetromino@gentoo.org>
-Date: Sun, 16 Jun 2013 13:36:08 -0400
-Subject: [PATCH] Update PIL import statements for compatibility with Pillow
- (PIL-2)
-
-https://bugs.gentoo.org/show_bug.cgi?id=471522
----
- install.py          | 2 +-
- mime/comicthumb     | 2 +-
- src/comix.py        | 2 +-
- src/histogram.py    | 6 +++---
- src/image.py        | 8 ++++----
- src/library.py      | 4 ++--
- src/thumbbar.py     | 4 ++--
- src/thumbnail.py    | 2 +-
- src/thumbremover.py | 2 +-
- 9 files changed, 16 insertions(+), 16 deletions(-)
-
-diff --git a/install.py b/install.py
-index f8be7cb..d72d8d1 100755
---- a/install.py
-+++ b/install.py
-@@ -240,7 +240,7 @@ def check_dependencies():
-         print '    !!! PyGTK .................... Not found'
-         required_found = False
-     try:
--        import Image
-+        from PIL import Image
-         assert Image.VERSION >= '1.1.5'
-         print '    Python Imaging Library ....... OK'
-     except ImportError:
-diff --git a/mime/comicthumb b/mime/comicthumb
-index 1081dac..a3e6a83 100755
---- a/mime/comicthumb
-+++ b/mime/comicthumb
-@@ -22,7 +22,7 @@ import tarfile
- import subprocess
- try:
--    import Image
-+    from PIL import Image
- except ImportError:
-     print '! Could not import the Image module (PIL).'
-     print __doc__
-diff --git a/src/comix.py b/src/comix.py
-index f3f9e1b..ebc73e9 100755
---- a/src/comix.py
-+++ b/src/comix.py
-@@ -51,7 +51,7 @@ except ImportError:
-     sys.exit(1)
- try:
--    import Image
-+    from PIL import Image
-     assert Image.VERSION >= '1.1.5'
- except AssertionError:
-     print "You don't have the required version of the Python Imaging",
-diff --git a/src/histogram.py b/src/histogram.py
-index e9fc68d..42ac9b8 100644
---- a/src/histogram.py
-+++ b/src/histogram.py
-@@ -1,9 +1,9 @@
- """histogram.py - Draw histograms (RGB) from pixbufs."""
- import gtk
--import Image
--import ImageDraw
--import ImageOps
-+from PIL import Image
-+from PIL import ImageDraw
-+from PIL import ImageOps
- import image
-diff --git a/src/image.py b/src/image.py
-index 0603f0a..db51525 100644
---- a/src/image.py
-+++ b/src/image.py
-@@ -1,10 +1,10 @@
- """image.py - Various image manipulations."""
- import gtk
--import Image
--import ImageEnhance
--import ImageOps
--import ImageStat
-+from PIL import Image
-+from PIL import ImageEnhance
-+from PIL import ImageOps
-+from PIL import ImageStat
- from preferences import prefs
-diff --git a/src/library.py b/src/library.py
-index a4fc29b..e14a197 100644
---- a/src/library.py
-+++ b/src/library.py
-@@ -8,8 +8,8 @@ from xml.sax.saxutils import escape as xmlescape
- import gtk
- import gobject
- import pango
--import Image
--import ImageDraw
-+from PIL import Image
-+from PIL import ImageDraw
- import archive
- import encoding
-diff --git a/src/thumbbar.py b/src/thumbbar.py
-index ba4b94c..0a4c33f 100644
---- a/src/thumbbar.py
-+++ b/src/thumbbar.py
-@@ -4,8 +4,8 @@ import urllib
- import gtk
- import gobject
--import Image
--import ImageDraw
-+from PIL import Image
-+from PIL import ImageDraw
- import image
- from preferences import prefs
-diff --git a/src/thumbnail.py b/src/thumbnail.py
-index 25f333e..b565162 100644
---- a/src/thumbnail.py
-+++ b/src/thumbnail.py
-@@ -15,7 +15,7 @@ import shutil
- import tempfile
- import gtk
--import Image
-+from PIL import Image
- import archive
- import constants
-diff --git a/src/thumbremover.py b/src/thumbremover.py
-index fc2fa37..03aa6e6 100644
---- a/src/thumbremover.py
-+++ b/src/thumbremover.py
-@@ -7,7 +7,7 @@ import urllib
- import gtk
- import pango
--import Image
-+from PIL import Image
- import encoding
- import labels
--- 
-1.8.2.1
-
diff --git a/media-gfx/comix/metadata.xml b/media-gfx/comix/metadata.xml
deleted file mode 100644 (file)
index 590b345..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <maintainer type="project">
-               <email>graphics@gentoo.org</email>
-               <name>Gentoo Graphics Project</name>
-       </maintainer>
-       <use>
-               <flag name="rar">
-               Pulls app-arch/unrar for rar file support
-       </flag>
-       </use>
-       <upstream>
-               <remote-id type="sourceforge">comix</remote-id>
-       </upstream>
-</pkgmetadata>
index c038f8b8fd58ae58b8fff7796fd692fa82b35c13..f812ad71b8d65573b1ec1edd44617d20754ff9e6 100644 (file)
@@ -485,11 +485,6 @@ sys-apps/entropy-server
 # Masked for removal in 30 days.
 games-strategy/boswars
 
-# Andreas Sturmlechner <asturm@gentoo.org> (2020-02-22)
-# Last release in 2009, py2-only, blocks dev-python/pygtk removal, bug #708100
-# Use media-gfx/mcomix instead. Masked for removal in 30 days.
-media-gfx/comix
-
 # Andreas Sturmlechner <asturm@gentoo.org> (2020-02-19)
 # No maintainer, py2-only, blocks dev-python/pygtk removal, needs version bump
 # See bugs #546024, #706486, pending PR #14720. Masked for removal in 40 days.