dev-python/django_polymorphic: Bump to 2.1.2, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 12:01:03 +0000 (14:01 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Apr 2020 12:05:04 +0000 (14:05 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/django_polymorphic/Manifest
dev-python/django_polymorphic/django_polymorphic-2.1.2.ebuild [new file with mode: 0644]

index 99ad4c9248454a2555de3f017357cf26971b97c4..464355cce55d1a10f0b6a728a3578252710c0b20 100644 (file)
@@ -1 +1,2 @@
 DIST django_polymorphic-2.0.3.tar.gz 100447 BLAKE2B 0a86212810d5a51637faa5b431355fcbe66ac7a14fbdf09952edde8895c7d53f46de8dd00d0e778eec8c141a9020b7775577489d94f4eff6d129ecbebcbf5e5a SHA512 0ef4877820d7761bf603506d81fe7fe9121e8de9db7e0ef225f87f43a3c32b1b51fffbe4cd246fa94fac95c99b8a36f844c0109e1770eeca9e5051fe529e6f1a
+DIST django_polymorphic-2.1.2.tar.gz 103555 BLAKE2B b55764e4b2d48bd33fc9b62852c048981a80480bd5cd4603dc37cc5b8ee54a5e2558c99c11b3588910e577a1b28dd979ca82df49f788579c91129402be2abf73 SHA512 f23f3bbfd3e8a072804d374d5c7fa8f5ceb596463942795be303a2a349b1804e66adee445602ae263ec0b71894d9ad4a6712bad19c70320a6f87e07e97dbffef
diff --git a/dev-python/django_polymorphic/django_polymorphic-2.1.2.ebuild b/dev-python/django_polymorphic/django_polymorphic-2.1.2.ebuild
new file mode 100644 (file)
index 0000000..b3ba192
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Seamless Polymorphic Inheritance for Django Models"
+HOMEPAGE="https://pypi.org/project/django-polymorphic/"
+SRC_URI="https://github.com/django-polymorphic/django-polymorphic/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//_/-}"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/django-1.11[$PYTHON_USEDEP]
+"
+
+DEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/dj-database-url[${PYTHON_USEDEP}]
+       )
+"
+
+python_test() {
+       "${EPYTHON}" runtests.py || die "Tests fail with ${EPYTHON}"
+}