dev-perl/AnyEvent: Bump to version 7.170.0
authorKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 22:59:25 +0000 (10:59 +1200)
committerKent Fredric <kentnl@gentoo.org>
Thu, 23 Apr 2020 23:00:07 +0000 (11:00 +1200)
- EAPI7-ify
- Improve testing situation to be clearer to testers what additional
  steps should be done to maximise test coverage.

Upstream:
- AnyEvent::Handle::tls_detect now passes seperate major and minor
  values as documentation suggested, instead of only one.
- Workaround Net::SSLeay lacking openssl 1.1 porting.
- AnyEvent::DNS::dns_unpack now stores original packet in the __ member
  to allow decoding otherwise undecodable resource records containing
  compressed domain names
- AnyEvent::Socket::parse_ipv6 now handles ipv4 addresses as documented.
- Support CAA records
- Add freenom and cloudflare NS as DNS fallback
- AnyEvent::Strict now properly wards against watchers on files when
  file handle passed is a file descriptor
- Add ffdhe group dh parameters and use fdhe3072 as default instead of
  schmorp1539
- AnyEvent::Log now reassesses logging status of loggers when contexts
  were changed via attach/detach/slaves, allowing more logging through
- Workaround old openssl in RHEL7 formatting dh parameters differently

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/AnyEvent/AnyEvent-7.170.0.ebuild [new file with mode: 0644]
dev-perl/AnyEvent/Manifest

diff --git a/dev-perl/AnyEvent/AnyEvent-7.170.0.ebuild b/dev-perl/AnyEvent/AnyEvent-7.170.0.ebuild
new file mode 100644 (file)
index 0000000..068d6a3
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=MLEHMANN
+DIST_VERSION=7.17
+inherit perl-module eutils virtualx
+
+DESCRIPTION="Provides a uniform interface to various event loops"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-solaris"
+
+BDEPEND="
+       >=virtual/perl-ExtUtils-MakeMaker-6.520.0
+       dev-perl/Canary-Stability
+"
+PERL_RM_FILES=(
+       # Requires AnyEvent::AIO form AnyEvent-AIO, not in ::gentoo
+       t/12_io_ioaio.t
+       # Requires Fltk from Fl, not in ::gentoo
+       t/61_fltk_0{1_basic,2_signals,3_child,4_condvar,5_dns,7_io,9_multi}.t
+       # Requires Cocoa::EventLoop, not in ::gentoo
+       t/62_cocoa_0{1_basic,2_signals,3_child,4_condvar,5_dns,7_io,9_multi}.t
+       # Requires IO::Async, not in ::gentoo
+       t/66_ioasync_0{1_basic,2_signals,3_child,4_condvar,5_dns,7_io,9_multi}.t
+       # Requires UV, not in ::gentoo
+       t/70_uv_0{1_basic,2_signals,3_child,4_condvar,5_dns,7_io,9_multi}.t
+
+)
+pkg_postinst() {
+       optfeature "improved event-loop performance"            '>=dev-perl/EV-4.0.0'
+       optfeature "improved performance of Guard objects"      '>=dev-perl/Guard-1.20.0'
+       optfeature "JSON relays over AnyEvent::Handle"          '>=dev-perl/JSON-2.90.0' '>=dev-perl/JSON-XS-2.200.0'
+       optfeature "SSL support for AnyEvent::Handle"           '>=dev-perl/Net-SSLeay-1.330.0'
+       # AnyEvent::AIO
+       # Async::Interrupts
+}
+src_test() {
+       # optional:
+       # - install dev-perl/glib-perl for Glib for AnyEvent::Impl::Glib
+       # - install dev-perl/Event for AnyEvent::Impl::Event
+       # - install dev-perl/Tk for AnyEvent::Impl::Tk
+       # - install dev-perl/POE for AnyEvent::Impl::POE
+       # - install dev-perl/EV for AnyEvent::Impl::EV
+       if ! has "network" ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}} ||
+          ! has_version "dev-perl/glib-perl" ||
+          ! has_version "dev-perl/Event" ||
+          ! has_version "dev-perl/Tk" ||
+          ! has_version "dev-perl/POE" ||
+          ! has_version "dev-perl/EV"; then
+               ewarn "This package needs network access and manually installed dependencies"
+               ewarn "for comprehensive testing. For details, see:"
+               ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/${CATEGORY}/${PN}"
+       fi
+       ( # export leak guard
+               export PERL_ANYEVENT_LOOP_TESTS=1
+
+               if has "network" ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+                       einfo "Network Tests Enabled"
+                       export PERL_ANYEVENT_NET_TESTS=1
+               fi
+               # This loop requires a display to even load the module
+               if has_version dev-perl/Tk; then
+                       virtx perl-module_src_test
+               else
+                       perl-module_src_test
+               fi
+       )
+}
index ad8c93e39207d282071ac085c8684a900d26fce0..5a25a532b461f1f533f262833f798624787a879d 100644 (file)
@@ -1 +1,2 @@
 DIST AnyEvent-7.14.tar.gz 301645 BLAKE2B 5095506e02ae90953d3990609ad77c45d602bd38a696ea054d329ee4e9fb526ac799ba45eb38f274835248d7e593257e7203daf1a7f17d5086f89413b93ddecf SHA512 98e7b9e06cf74b99d3407a25b60f3b825fceed3bae43505e1fb90785e24bd88ae25955cff25d29b4cc96957db7f4f5203d19ad2365abb4e3a3227fd91a16fb25
+DIST AnyEvent-7.17.tar.gz 304845 BLAKE2B 162b02080f009595a48b4cb7d205763fa96e97af5f9efbb9f1611bcf365ce3d1ded57d6bb45bd433a11346b12cfabcd1f44dc944bf0c9c1f85abfab355d9a32c SHA512 c553cce80fa14e2f91031c569d1c30acf470871ddd1c122fa3dd36cd1ba5b7002e7ba1dea4c950d889c7c661b81042dd97975e195a5325190ad644babff81e0a