dev-lang/gforth: make sanity checks optional
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 19 Mar 2020 23:31:34 +0000 (23:31 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 19 Mar 2020 23:35:44 +0000 (23:35 +0000)
Bug: https://bugs.gentoo.org/713138
Package-Manager: Portage-2.3.94, Repoman-2.3.21
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/gforth/gforth-0.7.3-r1.ebuild
dev-lang/gforth/metadata.xml

index 2697a44780a7ef66e073c2cf96cb53833f1e2798..01598f0f239e82fa8bdca803c324b205e27924f7 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/gforth/${P}.tar.gz"
 LICENSE="GPL-3"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris"
-IUSE="emacs"
+IUSE="+check emacs"
 
 DEPEND="dev-libs/ffcall
        emacs? ( >=app-editors/emacs-23.1:* )"
@@ -26,7 +26,8 @@ PATCHES=(
 
 src_configure() {
        econf \
-               $(use emacs || echo "--without-lispdir")
+               $(use emacs || echo "--without-lispdir") \
+               $(use_with check)
 }
 
 src_compile() {
index c5298995d2d4f6ec4571d7a80ab5ed0a8d340206..03e8585377c7ede4d89f796f9a0e25606d78928c 100644 (file)
@@ -5,4 +5,7 @@
                <email>slyfox@gentoo.org</email>
                <name>Sergei Trofimovich</name>
        </maintainer>
+       <use>
+               <flag name='check'>Enable build-time sanity check.</flag>
+       </use>
 </pkgmetadata>