media-libs/zimg: Version bump (v2.9.2)
authorMikle Kolyada <zlogene@gentoo.org>
Sat, 26 Oct 2019 16:02:59 +0000 (19:02 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Sat, 26 Oct 2019 16:05:40 +0000 (19:05 +0300)
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
media-libs/zimg/Manifest
media-libs/zimg/zimg-2.9.2.ebuild [new file with mode: 0644]

index 812439a44b6f6268bb68deb3ef612a96281f4034..33a55d77fd70e5bc411f198f8f8594928552e736 100644 (file)
@@ -1 +1,2 @@
 DIST zimg-2.8.tar.gz 265363 BLAKE2B a8982c64325e0089617136fcd5d6ee429ab861e3b9445b9cc0292bd3bbd3abb5783e94983e3e802fd9e59c2c7089eeea176d1eda4f3a850379cfc4fb36cbc408 SHA512 1e89087a756798a7ae3bfae3bc8244b29ae8ae7f04f53bdf6c4d4de3cb11412dc1eecd95a4a121bb9077437e633f8fbb665522ff8112ade806d9191ea4b5f7bf
+DIST zimg-2.9.2.tar.gz 266049 BLAKE2B 214a6afec061dc7cc7c751f2a57e56951e44b78fea6a0c0dc71235d3dd286fb811303b0a5198ab82165ee78d993caabaf39d7ec17db4c4e5ffca9a3475b49781 SHA512 b688f8e93a2e4549f2c844cd58c6e0714e6494d6fc8c800dc1b0cdf2278fb9925a646fc332350c1b5d77cef2134bf35e18a873c24ea1979c1adce57bfef68ebe
diff --git a/media-libs/zimg/zimg-2.9.2.ebuild b/media-libs/zimg/zimg-2.9.2.ebuild
new file mode 100644 (file)
index 0000000..4e92e0e
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = *9999* ]] ; then
+       EGIT_REPO_URI="https://github.com/sekrit-twc/zimg"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/sekrit-twc/zimg/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+       S="${WORKDIR}/${PN}-release-${PV}/"
+fi
+inherit autotools multilib-minimal
+
+DESCRIPTION="Scaling, colorspace conversion, and dithering library"
+HOMEPAGE="https://github.com/sekrit-twc/zimg"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+IUSE="cpu_flags_x86_sse debug static-libs"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               $(use_enable debug) \
+               $(use_enable cpu_flags_x86_sse x86simd) \
+               $(use_enable static-libs static)
+}