dev-python/thunarx-python: Bump to 0.4.0 (masked)
authorMichał Górny <mgorny@gentoo.org>
Thu, 30 Nov 2017 16:00:23 +0000 (17:00 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 30 Nov 2017 16:00:59 +0000 (17:00 +0100)
dev-python/thunarx-python/Manifest
dev-python/thunarx-python/thunarx-python-0.4.0.ebuild [new file with mode: 0644]
profiles/package.mask

index 9832d095047634a6251852451b289854258a7751..0460cf4c04507601f964ca44e66f88c52965df97 100644 (file)
@@ -1 +1,2 @@
-DIST thunarx-python-0.3.0.tar.bz2 303035 SHA256 5650e045565af82f3a5f67bbecb46182b502a37f94d08c23adac697dbb4ce258 SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f WHIRLPOOL cfcf986b7ca9bc2fd50d4d5bbb80c6df7ac557e3ca15703eada5c71a302d4275cee7972d13cb3d746e064caeb9e90f366819045bc109d761bcc898ce5a70d577
+DIST thunarx-python-0.3.0.tar.bz2 303035 BLAKE2B af0193a3bc97c859ba98f52c612d5af81c5b7a0d8142a8283cf2b308fa183ac57ac1a2163cd882749b6fd33e0529f20f1f9e2db2dcc1aed26cb40cd5995780fb SHA512 9be3e8b50cd668e0b63fbf54da5dec3685dde40528067b35bd1cfa87db7e037962baafce3059818a7de76101472a2b07ae209c590f2f143dbc71646e8addb28f
+DIST thunarx-python-0.4.0.tar.bz2 332620 BLAKE2B 768a2a236e12d298efb3abc86f4a339548248f5f88366ec7d956249c028474612b15c340976ac2c2ced806a89517278c70b50069d76b2eee6af6dd097789e275 SHA512 fb54f83c11857ec2236a249895954efc29446120c192b8d19794b7e8145836969f87d1efa524bfaa4c9d31ee08a2c17a57d7210ce4a3a4982780d128839d02b1
diff --git a/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild b/dev-python/thunarx-python/thunarx-python-0.4.0.ebuild
new file mode 100644 (file)
index 0000000..5f28031
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Python bindings for the Thunar file manager"
+HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
+SRC_URI="mirror://xfce/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+       >=x11-libs/gtk+-3.20:3
+       >=dev-libs/glib-2.30:2
+       >=dev-python/pygobject-3.20:3[${PYTHON_USEDEP}]
+       >=xfce-base/thunar-1.7.0"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_install() {
+       default
+
+       find "${D}" -name '*.la' -delete || die
+}
index 4140daa2aed85f37bbb1fce873f1925144c36921..f6da8a489870fb7cf4011f4b196948b678ff6b68 100644 (file)
@@ -105,6 +105,7 @@ x11-drivers/xf86-input-pentouch
 # Michał Górny <mgorny@gentoo.org> (25 Nov 2017)
 # Testing branch GTK+3 release. Changes API, breaks xfce-base/xfdesktop.
 # Masked until the latter sees a new release.
+>=dev-python/thunarx-python-0.4.0
 >=xfce-base/thunar-1.7
 
 # Jonas Stein <jstein@gentoo.org> (25 Nov 2017)