virtual/opencl: fix amdgpu dependencies
authorMarek Szuba <marecki@gentoo.org>
Wed, 1 Apr 2020 20:57:14 +0000 (21:57 +0100)
committerMarek Szuba <marecki@gentoo.org>
Wed, 1 Apr 2020 21:15:01 +0000 (22:15 +0100)
1. Not sure if this is due to what upstream supports (like for both
   Intel providers) or because it has not been implemented - but
   either way, as of 2020-04-01 dev-libs/rocm-opencl-runtime neither is
   keyworded x86 nor supports multilib on amd64;
2. Conversely, dev-libs/amdgpu-pro-opencl does both so in order for
   multilib to work properly it should be passed $MULTILIB_USEDEP.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
virtual/opencl/opencl-2.ebuild

index 50fcd113e3166bea3d4a597194b047cb82933eeb..51ea03746deeca20449f9a600dd8cdca8c83903d 100644 (file)
@@ -11,7 +11,7 @@ KEYWORDS="amd64 x86"
 CARDS=( amdgpu i965 nvidia r600 radeonsi )
 IUSE="${CARDS[@]/#/video_cards_}"
 
-# intel-neo and intel-ocl-sdk are amd64-only
+# intel-neo, intel-ocl-sdk and rocm-opencl-runtime are abi_x86_64-only
 # ocl-icd is essentially a dummy/you-are-on-your-own provider - it installs
 # header files to include in the source code and a library to link against
 # but does not support any actual devices
@@ -21,8 +21,8 @@ RDEPEND="app-eselect/eselect-opencl
                        abi_x86_64? ( !abi_x86_32? ( dev-libs/intel-neo ) )
                )
                video_cards_amdgpu? ( || (
-                       dev-libs/rocm-opencl-runtime
-                       dev-libs/amdgpu-pro-opencl ) )
+                       abi_x86_64? ( !abi_x86_32? ( dev-libs/rocm-opencl-runtime ) )
+                       dev-libs/amdgpu-pro-opencl[${MULTILIB_USEDEP}] ) )
                video_cards_nvidia? ( || (
                        >=x11-drivers/nvidia-drivers-290.10-r2[uvm(-)]
                        >=media-libs/mesa-9.1.6[opencl,X(+),${MULTILIB_USEDEP}] ) )