dev-python/odfpy: bump to 1.3.6
authorVirgil Dupras <vdupras@gentoo.org>
Tue, 7 Aug 2018 15:13:31 +0000 (11:13 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Tue, 7 Aug 2018 15:13:31 +0000 (11:13 -0400)
* Run tests properly (they pass now)
* Use github release tarball to have complete content (for tests)
* EAPI 7
* Python 3.7

Package-Manager: Portage-2.3.44, Repoman-2.3.10

dev-python/odfpy/Manifest
dev-python/odfpy/odfpy-1.3.6.ebuild [new file with mode: 0644]

index 9cb087482d76ade951b4ec0ce8714ce9f28dcae9..ecc587cfd1c58d1a4b39e1b9aabc9d60d999d47c 100644 (file)
@@ -1 +1,2 @@
 DIST odfpy-1.3.2.tar.gz 479554 BLAKE2B 3b9d2d144f11727471002dd1dfb9289028423d05d65fea040041dbd43a674ddf6c893fa8895a2e198e6a82e79aa2af92f21a6381cfd67233b4fe57401370121f SHA512 c5be79c4077f40a56821790d4b6062e3715f8b616b1e9ead79977ad00ecf3f506ebbe73790f215bb835a233833fa471af7f619cfcd88320cf8238e4c9502e248
+DIST odfpy-1.3.6.tar.gz 691122 BLAKE2B aaaf2c1613beb6775d22e4d1739b7c144d8046e687f0dc8f7b7b1ea7400cc32dd572ed5a1cd12cb01c5fec27b5c37950b710b279a46d60da8735154d2b2d7030 SHA512 09f3fbce633949035842cff16d2e016271b7f6abf04d74fcaa712c9b3afa18943dd566a2d88a7256a0a52d88ea689d6ef8262f6d8d67d6ea1025aa56e10300f8
diff --git a/dev-python/odfpy/odfpy-1.3.6.ebuild b/dev-python/odfpy/odfpy-1.3.6.ebuild
new file mode 100644 (file)
index 0000000..61a31f5
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Classifier: Programming Language :: Python :: 2 :: Only
+# py3 fails one test, pypy anpother.
+# Notes on page of home repo reports support of python3.
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://github.com/eea/odfpy https://pypi.org/project/odfpy/"
+SRC_URI="https://github.com/eea/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       pytest -v || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+       use examples && local EXAMPLES=( examples/. )
+       distutils-r1_python_install_all
+}