app-text/par: 1.53.0 + EAPI 7 + tests
authorSebastian Pipping <sping@gentoo.org>
Sun, 22 Mar 2020 04:20:01 +0000 (05:20 +0100)
committerSebastian Pipping <sping@gentoo.org>
Sun, 22 Mar 2020 04:24:03 +0000 (05:24 +0100)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.92, Repoman-2.3.20

app-text/par/Manifest
app-text/par/par-1.53.0.ebuild [new file with mode: 0644]

index b1107a021b1201e1d3bbefe0e69b8ec183f2bafa..803190f46083d32f7229eb76ce25d11d4fc26424 100644 (file)
@@ -1 +1,2 @@
+DIST Par-1.53.0.tar.gz 52209 BLAKE2B 4069f75e1d0ff397938941ab58020c41cb1b896ab91b370c4f9c9a4d4eea1fe695cc0c27b0129780d40b7274e355ac1f41a933d051bffebc938c284e71971fe6 SHA512 3f8ac57fe19ebcf427b11f4d79f2c5cc9286c1439c38a53d45bd29b9219369db2798efbd0e203ac359d59ebbdd3ead1c50ae75352a1ffc568d4d3b9ad50642b1
 DIST Par152.tar.gz 47999 BLAKE2B 0f76abde64d00d0511d9b0b0ce2a97b13917e08fe3bd1c69fa98ca19dff75a2b55a21f5eaa8bfd0660b6523336de6c29b2a58647196ff6af8c24ec156a426bb0 SHA512 f5a46da4b693e6a3d15ccd57e24ee9b0332ebfbcfc88da9ef0731e18932ba6f0adde7691a233264d6361e8903ff7e2263f71885a415c896dc4c45a0d05b1978e
diff --git a/app-text/par/par-1.53.0.ebuild b/app-text/par/par-1.53.0.ebuild
new file mode 100644 (file)
index 0000000..3165b8c
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="Par-${PV}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
+HOMEPAGE="http://www.nicemice.net/par/"
+SRC_URI="http://www.nicemice.net/par/${MY_P}.tar.gz"
+
+LICENSE="|| ( MIT par )"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="!dev-util/par
+       !app-arch/par"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       emake -f protoMakefile CC="$(tc-getCC) ${CFLAGS} -c" \
+               LINK1="$(tc-getCC) ${LDFLAGS}"
+}
+
+src_install() {
+       newbin par par-format
+       doman par.1
+       dodoc releasenotes par.doc
+}
+
+src_test() {
+       emake -f protoMakefile test
+}