www-apps/mythweb: Drop 0.27.5
authorAndreas Sturmlechner <asturm@gentoo.org>
Fri, 11 Aug 2017 15:04:01 +0000 (17:04 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Fri, 11 Aug 2017 15:11:13 +0000 (17:11 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

www-apps/mythweb/Manifest
www-apps/mythweb/mythweb-0.27.5.ebuild [deleted file]

index e6e7209addd47b25c6d4405c2822a1017c65c2c3..73ee467a47bdec5f63bd01fefb50b2d5a6499ba5 100644 (file)
@@ -1,2 +1 @@
-DIST mythweb-0.27.5.tar.gz 1686597 SHA256 5dc3fd9e60f59dea4264fb064b40d73f2534c99d0399da6223a42d2f563e9d13 SHA512 effa5f9cab6b40423a819f0307aecd1faa397da7d859503162b6229e5da2d4cd0d95d793326768335518cd397fa58ba71ad98c14247feda10e7930f7e023f1af WHIRLPOOL 8721398611db0572f475f5642c397a5d3f0fbe352f0f3ea23dc21cc0ea94e0e6876a713cf0f99331c6fc1f585a62525dc64510737a85667c0e2a14b6f1c6bb10
 DIST mythweb-0.28.1.tar.gz 1705490 SHA256 bbd82992230d3571eba55a26a91cc3f2dcddfa631d1822ce58e1bf99f2537244 SHA512 0ce9e2c7138d35ef59859a8a8980b01d90d9b616e55653fb28dd5a473199446508e525171687383ce83051b434f5e7618f509a9e75cd84296446ee450733e963 WHIRLPOOL b36f3226a9984d4c7ea383e1344ddb630b06972fd3170cdcbd0521f9bad3b7acf24f94c7e7099812f8fe5eeea17ab115a36a38ea0b07617998011c7f7c545e00
diff --git a/www-apps/mythweb/mythweb-0.27.5.ebuild b/www-apps/mythweb/mythweb-0.27.5.ebuild
deleted file mode 100644 (file)
index a2a3612..0000000
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils webapp
-
-#BACKPORTS="4f6ac2a60b"
-# Release version
-MY_PV="${PV%_p*}"
-MY_P="mythweb-${MY_PV}"
-
-DESCRIPTION="PHP scripts intended to manage MythTV from a web browser"
-HOMEPAGE="http://www.mythtv.org"
-LICENSE="GPL-2"
-SRC_URI="https://github.com/MythTV/mythweb/archive/v${MY_PV}.tar.gz -> mythweb-${MY_PV}.tar.gz
-       ${BACKPORTS:+https://dev.gentoo.org/~cardoe/distfiles/${MY_P}-${BACKPORTS}.tar.xz}"
-IUSE=""
-KEYWORDS="~amd64 ~ppc ~x86"
-
-RDEPEND="dev-lang/php[json,mysql,session,posix]
-       virtual/httpd-php
-       dev-perl/DBI
-       dev-perl/DBD-mysql
-       dev-perl/HTTP-Date
-       dev-perl/Net-UPnP"
-
-DEPEND="${RDEPEND}"
-
-need_httpd_cgi
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
-       cd "${S}"/../
-
-       [[ -n ${BACKPORTS} ]] && \
-               EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${S}/../patches" \
-                       epatch
-
-       epatch_user
-}
-
-src_configure() {
-       :
-}
-
-src_compile() {
-       :
-}
-
-src_install() {
-       webapp_src_preinst
-
-       # Install docs
-       cd "${S}"
-       dodoc README INSTALL
-
-       # Install htdocs files
-       insinto "${MY_HTDOCSDIR}"
-       doins mythweb.php
-       doins -r classes
-       doins -r configuration
-       doins -r data
-       doins -r includes
-       doins -r js
-       doins -r modules
-       doins -r skins
-       doins -r tests
-       exeinto "${MY_HTDOCSDIR}"
-       doexe mythweb.pl
-
-       # Install our server config files
-       webapp_server_configfile apache mythweb.conf.apache mythweb.conf
-       webapp_server_configfile lighttpd mythweb.conf.lighttpd mythweb.conf
-       webapp_server_configfile nginx "${FILESDIR}"/mythweb.conf.nginx \
-               mythweb.include
-
-       # Data needs to be writable and modifiable by the web server
-       webapp_serverowned -R "${MY_HTDOCSDIR}"/data
-
-       # Message to display after install
-       webapp_postinst_txt en "${FILESDIR}"/0.25-postinstall-en.txt
-
-       # Script to set the correct defaults on install
-       webapp_hook_script "${FILESDIR}"/reconfig
-
-       webapp_src_install
-}