app-emulation/qemu: drop USE=uuid in newer versions #606506
authorMike Frysinger <vapier@gentoo.org>
Fri, 20 Jan 2017 17:20:50 +0000 (11:20 -0600)
committerMike Frysinger <vapier@gentoo.org>
Fri, 20 Jan 2017 17:21:57 +0000 (11:21 -0600)
Qemu always builds in their own uuid generation logic now and never looks
at the external libuuid, so they've dropped the configure flag to match.

app-emulation/qemu/qemu-2.8.0.ebuild
app-emulation/qemu/qemu-9999.ebuild

index de01f6ce5a5eeec59fbcd763ec8d5ad353ec8424..29ca032567634c377e4aa48fb22227608759c591 100644 (file)
@@ -30,7 +30,7 @@ gnutls gtk gtk2 infiniband iscsi +jpeg \
 kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs
 +png pulseaudio python \
 rbd sasl +seccomp sdl sdl2 selinux smartcard snappy spice ssh static static-softmmu
-static-user systemtap tci test +threads usb usbredir +uuid vde +vhost-net \
+static-user systemtap tci test +threads usb usbredir vde +vhost-net \
 virgl virtfs +vnc vte xattr xen xfs"
 
 COMMON_TARGETS="aarch64 alpha arm cris i386 m68k microblaze microblazeel mips
@@ -133,7 +133,6 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
        ssh? ( >=net-libs/libssh2-1.2.8[static-libs(+)] )
        usb? ( >=virtual/libusb-1-r2[static-libs(+)] )
        usbredir? ( >=sys-apps/usbredir-0.6[static-libs(+)] )
-       uuid? ( >=sys-apps/util-linux-2.16.0[static-libs(+)] )
        vde? ( net-misc/vde[static-libs(+)] )
        virgl? ( media-libs/virglrenderer[static-libs(+)] )
        virtfs? ( sys-libs/libcap )
@@ -429,7 +428,6 @@ qemu_src_configure() {
                $(conf_softmmu ssh libssh2)
                $(conf_softmmu usb libusb)
                $(conf_softmmu usbredir usb-redir)
-               $(conf_softmmu uuid)
                $(conf_softmmu vde)
                $(conf_softmmu vhost-net)
                $(conf_softmmu virgl virglrenderer)
index 8b5b30ce4a07ec867ccefc1f30f45462d5203243..09a1c73df737fe94b93e55283b13de44c27993d1 100644 (file)
@@ -30,7 +30,7 @@ gnutls gtk gtk2 infiniband iscsi +jpeg \
 kernel_linux kernel_FreeBSD lzo ncurses nfs nls numa opengl +pin-upstream-blobs
 +png pulseaudio python \
 rbd sasl +seccomp sdl sdl2 selinux smartcard snappy spice ssh static static-softmmu
-static-user systemtap tci test +threads usb usbredir +uuid vde +vhost-net \
+static-user systemtap tci test +threads usb usbredir vde +vhost-net \
 virgl virtfs +vnc vte xattr xen xfs"
 
 COMMON_TARGETS="aarch64 alpha arm cris i386 m68k microblaze microblazeel mips
@@ -133,7 +133,6 @@ SOFTMMU_LIB_DEPEND="${COMMON_LIB_DEPEND}
        ssh? ( >=net-libs/libssh2-1.2.8[static-libs(+)] )
        usb? ( >=virtual/libusb-1-r2[static-libs(+)] )
        usbredir? ( >=sys-apps/usbredir-0.6[static-libs(+)] )
-       uuid? ( >=sys-apps/util-linux-2.16.0[static-libs(+)] )
        vde? ( net-misc/vde[static-libs(+)] )
        virgl? ( media-libs/virglrenderer[static-libs(+)] )
        virtfs? ( sys-libs/libcap )
@@ -425,7 +424,6 @@ qemu_src_configure() {
                $(conf_softmmu ssh libssh2)
                $(conf_softmmu usb libusb)
                $(conf_softmmu usbredir usb-redir)
-               $(conf_softmmu uuid)
                $(conf_softmmu vde)
                $(conf_softmmu vhost-net)
                $(conf_softmmu virgl virglrenderer)