New package for gnome-2.14 release. Applet to make searching and common actions a...
authorJoe McCann <joem@gentoo.org>
Mon, 13 Mar 2006 01:59:00 +0000 (01:59 +0000)
committerJoe McCann <joem@gentoo.org>
Mon, 13 Mar 2006 01:59:00 +0000 (01:59 +0000)
Package-Manager: portage-2.1_pre5-r4

gnome-extra/deskbar-applet/ChangeLog [new file with mode: 0644]
gnome-extra/deskbar-applet/Manifest [new file with mode: 0644]
gnome-extra/deskbar-applet/deskbar-applet-2.14.0.ebuild [new file with mode: 0644]
gnome-extra/deskbar-applet/files/deskbar-applet-2.13.91-multilib.patch [new file with mode: 0644]
gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.14.0 [new file with mode: 0644]
gnome-extra/deskbar-applet/metadata.xml [new file with mode: 0644]

diff --git a/gnome-extra/deskbar-applet/ChangeLog b/gnome-extra/deskbar-applet/ChangeLog
new file mode 100644 (file)
index 0000000..bcd1d01
--- /dev/null
@@ -0,0 +1,13 @@
+# ChangeLog for gnome-extra/deskbar-applet
+# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/ChangeLog,v 1.1 2006/03/13 01:59:00 joem Exp $
+
+*deskbar-applet-2.14.0 (13 Mar 2006)
+
+  13 Mar 2006; Joe McCann <joem@gentoo.org>
+  +files/deskbar-applet-2.13.91-multilib.patch,
+  +deskbar-applet-2.14.0.ebuild:
+  New package for gnome-2.14 release. Applet to make searching and common
+  actions a bit easier. Patches and fixes from compnerd and dang during dev
+  cycle.
+
diff --git a/gnome-extra/deskbar-applet/Manifest b/gnome-extra/deskbar-applet/Manifest
new file mode 100644 (file)
index 0000000..d995d99
--- /dev/null
@@ -0,0 +1,15 @@
+MD5 4ad8df5dbef15d5c0c6a9891f2ddaf79 ChangeLog 546
+RMD160 90ea672c89e0e9a4249958b1a783eb1df13907c0 ChangeLog 546
+SHA256 c14ad00e67f850903204bb03607a152014a9154d895dcded72e9f53d3a713bc9 ChangeLog 546
+MD5 876faa0189567473691a3c7ccaddd7a7 deskbar-applet-2.14.0.ebuild 1079
+RMD160 f5224a01df47648329cb273b2fe009409b14592b deskbar-applet-2.14.0.ebuild 1079
+SHA256 30764678a25a9790dd6b2afe9aa2c0a43dc2e732737561445592fc50e51dca10 deskbar-applet-2.14.0.ebuild 1079
+MD5 8e8fdbd5aa2d0ab8bf18c380813c4ab0 files/deskbar-applet-2.13.91-multilib.patch 3380
+RMD160 79216ae3fdd67cc68d04453b612cbb5339bb2582 files/deskbar-applet-2.13.91-multilib.patch 3380
+SHA256 28e4c47803164b6f01ab7092812b03ab3d7360900b76e4ddb0e680f403453702 files/deskbar-applet-2.13.91-multilib.patch 3380
+MD5 283e99b5591521c849e9e70bc8d3aca8 files/digest-deskbar-applet-2.14.0 268
+RMD160 dd27937cfc13268e2ef35227e80f673770a0eaed files/digest-deskbar-applet-2.14.0 268
+SHA256 66ee5d1b2b4622a715a297d69db2eecfdbf242fe6c6eb3c162b0cc89c3789eee files/digest-deskbar-applet-2.14.0 268
+MD5 c96fe9e3f7052e7e1e929b940d8bb263 metadata.xml 413
+RMD160 b43b823b1de922a86e22ab10f0f11954f51cebaa metadata.xml 413
+SHA256 1388b8a4eeeec86628d3669c5fa22e9491e2ce21b8b76ad43a6b5b6b6c9fa6e2 metadata.xml 413
diff --git a/gnome-extra/deskbar-applet/deskbar-applet-2.14.0.ebuild b/gnome-extra/deskbar-applet/deskbar-applet-2.14.0.ebuild
new file mode 100644 (file)
index 0000000..6df1cb9
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/deskbar-applet/deskbar-applet-2.14.0.ebuild,v 1.1 2006/03/13 01:59:00 joem Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="An Omnipresent Versatile Search Interface"
+HOMEPAGE="http://raphael.slinckx.net/deskbar/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="eds"
+
+RDEPEND=">=dev-lang/python-2.3
+                >=x11-libs/gtk+-2.6
+                >=dev-python/pygtk-2.6
+                >=dev-python/gnome-python-2.10
+                >=gnome-base/gnome-desktop-2.10
+                >=dev-python/gnome-python-extras-2.12
+                >=gnome-base/gconf-2
+                eds? ( >=gnome-extra/evolution-data-server-1.2 )
+                sys-devel/gettext"
+DEPEND="${RDEPEND}
+               >=dev-util/intltool-0.33
+               dev-util/pkgconfig"
+
+pkg_setup() {
+       G2CONF="${G2CONF} $(use_enable eds evolution) --exec-prefix=/usr"
+}
+
+src_unpack() {
+       unpack ${A}
+       cd ${S}
+
+       # Fix installing libs into pythondir
+       epatch ${FILESDIR}/${PN}-2.13.91-multilib.patch
+
+       automake || die "automake failed"
+       autoconf || die "autoconf failed"
+
+       gnome2_omf_fix
+}
diff --git a/gnome-extra/deskbar-applet/files/deskbar-applet-2.13.91-multilib.patch b/gnome-extra/deskbar-applet/files/deskbar-applet-2.13.91-multilib.patch
new file mode 100644 (file)
index 0000000..49e5e1d
--- /dev/null
@@ -0,0 +1,55 @@
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.13.91.orig/deskbar/evolution/Makefile.am deskbar-applet-2.13.91/deskbar/evolution/Makefile.am
+--- deskbar-applet-2.13.91.orig/deskbar/evolution/Makefile.am  2005-10-20 15:28:19.000000000 -0400
++++ deskbar-applet-2.13.91/deskbar/evolution/Makefile.am       2006-02-20 11:23:10.000000000 -0500
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(EVOLUTION_CFLAGS)
+-_evolutiondir = $(pythondir)/deskbar/evolution
++_evolutiondir = $(pyexecdir)/deskbar/evolution
+ _evolution_LTLIBRARIES = _evolution.la
+ _evolution_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_evolution
+ _evolution_la_LIBADD = $(EVOLUTION_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.13.91.orig/deskbar/gnomedesktop/Makefile.am deskbar-applet-2.13.91/deskbar/gnomedesktop/Makefile.am
+--- deskbar-applet-2.13.91.orig/deskbar/gnomedesktop/Makefile.am       2005-11-06 19:44:14.000000000 -0500
++++ deskbar-applet-2.13.91/deskbar/gnomedesktop/Makefile.am    2006-02-20 11:23:10.000000000 -0500
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+-_gnomedesktopdir = $(pythondir)/deskbar/gnomedesktop
++_gnomedesktopdir = $(pyexecdir)/deskbar/gnomedesktop
+ _gnomedesktop_LTLIBRARIES = _gnomedesktop.la
+ _gnomedesktop_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_gnomedesktop
+ _gnomedesktop_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.13.91.orig/deskbar/iconentry/Makefile.am deskbar-applet-2.13.91/deskbar/iconentry/Makefile.am
+--- deskbar-applet-2.13.91.orig/deskbar/iconentry/Makefile.am  2005-09-13 19:35:00.000000000 -0400
++++ deskbar-applet-2.13.91/deskbar/iconentry/Makefile.am       2006-02-20 11:23:10.000000000 -0500
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+-_iconentrydir = $(pythondir)/deskbar/iconentry
++_iconentrydir = $(pyexecdir)/deskbar/iconentry
+ _iconentry_LTLIBRARIES = _iconentry.la
+ _iconentry_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_iconentry
+ _iconentry_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.13.91.orig/deskbar/keybinder/Makefile.am deskbar-applet-2.13.91/deskbar/keybinder/Makefile.am
+--- deskbar-applet-2.13.91.orig/deskbar/keybinder/Makefile.am  2005-10-06 10:11:52.000000000 -0400
++++ deskbar-applet-2.13.91/deskbar/keybinder/Makefile.am       2006-02-20 11:23:10.000000000 -0500
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+-_keybinderdir = $(pythondir)/deskbar/keybinder
++_keybinderdir = $(pyexecdir)/deskbar/keybinder
+ _keybinder_LTLIBRARIES = _keybinder.la
+ _keybinder_la_LDFLAGS = -module -avoid-version -export-symbols-regex init_keybinder
+ _keybinder_la_LIBADD = $(DESKBAR_LIBS)
+diff --exclude-from=/home/dang/.diffrc -u -ruN deskbar-applet-2.13.91.orig/deskbar/osutils/Makefile.am deskbar-applet-2.13.91/deskbar/osutils/Makefile.am
+--- deskbar-applet-2.13.91.orig/deskbar/osutils/Makefile.am    2006-02-09 20:36:08.000000000 -0500
++++ deskbar-applet-2.13.91/deskbar/osutils/Makefile.am 2006-02-20 11:23:37.000000000 -0500
+@@ -1,6 +1,6 @@
+ INCLUDES = $(PYTHON_INCLUDES) $(DESKBAR_CFLAGS)
+-_osutilsdir = $(pythondir)/deskbar/osutils
++_osutilsdir = $(pyexecdir)/deskbar/osutils
+ _osutils_LTLIBRARIES = _osutils.la
+ _osutils_la_LDFLAGS = -module -avoid-version init_osutils
+ _osutils_la_LIBADD = $(DESKBAR_LIBS)
diff --git a/gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.14.0 b/gnome-extra/deskbar-applet/files/digest-deskbar-applet-2.14.0
new file mode 100644 (file)
index 0000000..f5d70ab
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 2c9910160c2814e6497c5d6b6887fa8e deskbar-applet-2.14.0.tar.bz2 488808
+RMD160 2270eb01c6ebf569fe90839613116a5e1e7070cb deskbar-applet-2.14.0.tar.bz2 488808
+SHA256 eadc9313738d305adf4c15cd41823a5362d389fa09b868745ebbf098c83c6d02 deskbar-applet-2.14.0.tar.bz2 488808
diff --git a/gnome-extra/deskbar-applet/metadata.xml b/gnome-extra/deskbar-applet/metadata.xml
new file mode 100644 (file)
index 0000000..a37a1d3
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>gnome</herd>
+       <longdescription lang="en">
+               The goal of DeskbarApplet is to provide an omnipresent versatile search
+               interface. By typing search terms into the deskbar entry in your panel
+               you are presented with the search results as you type.
+       </longdescription>
+</pkgmetadata>
+