x11-misc/libinput-gestures: version bump for dependency compatibility
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>
Thu, 6 Jul 2017 15:41:35 +0000 (18:41 +0300)
committerDavid Seifert <soap@gentoo.org>
Sun, 30 Jul 2017 14:54:38 +0000 (16:54 +0200)
1. Add python 3.6 to PYTHON_COMPAT
2. Depend on libinput 1.8 because of commpatibility issue
3. Bump to 2.26 and update live ebuild

Bug: https://bugs.gentoo.org/show_bug.cgi?id=623800
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/5053

x11-misc/libinput-gestures/Manifest
x11-misc/libinput-gestures/libinput-gestures-2.26.ebuild [new file with mode: 0644]
x11-misc/libinput-gestures/libinput-gestures-9999.ebuild

index c8560be16c56217a819d626b9b3370c4e750b850..1c79c9758af10aedfcc92867487c202b17112b13 100644 (file)
@@ -1,2 +1,3 @@
 DIST libinput-gestures-2.15.tar.gz 11468 SHA256 95a91a2c7c4c9f91c035f7defb6868a92f6c61218d0fcb0a87b0fa63527c2912 SHA512 b0449ce3355e700655cf450b62e239566f2a49127bb4afeda659e04026657d86f13dbfd101399428771b92323e6c55cf40f75bad79025ff80eb9003d85345c23 WHIRLPOOL 9ff81290ecadc17bf2fbfeeb0a5ce1ff0adb059c1675f111a18144f13ac058f5efda445f139fb6158b17ec81a0b6014400d9c54fa8c393f206f4e4c71382b310
 DIST libinput-gestures-2.19.tar.gz 13031 SHA256 3f7cea70af6fc83f8d5910ef2a2a18955b0682b04c7a094ba6bcd46d912ddaaa SHA512 d67e5180e89dd1032fc16be6c6bb8b17f413bc41ebf2d92735fa444b23b5001ae37e243d1089f96308ea22a015b38c066ad8ca2a8f33feea247a51d6bf049d10 WHIRLPOOL 40d8b8715f2960454b843446548fc6106a56b21ca309089e077a2bf9ee4ea2b9ce0bc07025521de9f86851ce98a549e06baacf17923a7eb82e3424700674dbd3
+DIST libinput-gestures-2.26.tar.gz 15016 SHA256 378911de4f750f0959aeb27c9ed2c8be01ea6ce0c787d2d716110ff937fca584 SHA512 375c457c04f74d140693f6db0594b38f09c1a60eec89fa6e4b6da9b1d8d62abe42cf9e1a74214534f2b2f2a36d323521860bea722045b467d6bf2720a9c8c772 WHIRLPOOL 6df1993f29afb6759cea742b875ff3769064aa0cecbb64591e6517decca2bbab22ea2f5e75300ada4624ee8b22b4a22f6ce575eb7af0756e66762e3796b946c6
diff --git a/x11-misc/libinput-gestures/libinput-gestures-2.26.ebuild b/x11-misc/libinput-gestures/libinput-gestures-2.26.ebuild
new file mode 100644 (file)
index 0000000..5f7ead3
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit python-single-r1
+
+DESCRIPTION="Actions gestures on your touchpad using libinput"
+HOMEPAGE="https://github.com/bulletmark/${PN}"
+SRC_URI="https://github.com/bulletmark/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk kde"
+
+RDEPEND="${PYTHON_DEPS}
+       >=dev-libs/libinput-1.8.0
+       x11-misc/xdotool
+       x11-misc/wmctrl"
+DEPEND=">=dev-libs/libinput-1.8.0
+       dev-util/desktop-file-utils
+       gtk? ( x11-libs/gtk+:3 )
+       kde? ( kde-plasma/kde-cli-tools:5 )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_postinst() {
+       elog "You must be in the input group to read the touchpad device."
+}
index dd54500b3b4302a4fc0ce3d08962d3a7f6991d92..fcb47f0259821e1088c709b1cf6be4fb9f291699 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
 
 inherit git-r3 python-single-r1
 
@@ -18,10 +18,10 @@ KEYWORDS=""
 IUSE="gtk kde"
 
 RDEPEND="${PYTHON_DEPS}
-       dev-libs/libinput
+       >=dev-libs/libinput-1.8.0
        x11-misc/xdotool
        x11-misc/wmctrl"
-DEPEND="dev-libs/libinput
+DEPEND=">=dev-libs/libinput-1.8.0
        dev-util/desktop-file-utils
        gtk? ( x11-libs/gtk+:3 )
        kde? ( kde-plasma/kde-cli-tools:5 )"