dev-ros/rospack: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 12:04:54 +0000 (14:04 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 12:04:54 +0000 (14:04 +0200)
Package-Manager: portage-2.2.21

dev-ros/rospack/Manifest [new file with mode: 0644]
dev-ros/rospack/metadata.xml [new file with mode: 0644]
dev-ros/rospack/rospack-2.2.5.ebuild [new file with mode: 0644]
dev-ros/rospack/rospack-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/rospack/Manifest b/dev-ros/rospack/Manifest
new file mode 100644 (file)
index 0000000..80fef92
--- /dev/null
@@ -0,0 +1 @@
+DIST rospack-2.2.5.tar.gz 70273 SHA256 8602e21172ef453b63c6c6f1698c5ac81ec014b0a78bf98f31a60937dacee9ef SHA512 b685029e7306795459a1768050fd54e3eb82db91c0c3495410eeb6c6b3cb24b5d7f63cc5286d466659edb35719e76e4a43519526fd0c991fef2d7f9e092fd9e0 WHIRLPOOL 33191188ef39f817f48cdfbda407dc4d4bf288920b7e7b9a1b4b9ff383b87781a34fe7a3bfe734c8431c9e2cde19cadff1d70d84129de813bfbf2412a5728835
diff --git a/dev-ros/rospack/metadata.xml b/dev-ros/rospack/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rospack/rospack-2.2.5.ebuild b/dev-ros/rospack/rospack-2.2.5.ebuild
new file mode 100644 (file)
index 0000000..44ef9df
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=
+       dev-libs/tinyxml
+       "
+DEPEND="${RDEPEND}
+       dev-ros/cmake_modules
+       test? (
+               dev-cpp/gtest
+               dev-python/nose
+       )"
diff --git a/dev-ros/rospack/rospack-9999.ebuild b/dev-ros/rospack/rospack-9999.ebuild
new file mode 100644 (file)
index 0000000..44ef9df
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/rospack"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+# Do it that way to avoid ros-catkin pulling in python-r1
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+inherit python-single-r1
+
+DESCRIPTION="Retrieves information about ROS packages available on the filesystem"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=
+       dev-libs/tinyxml
+       "
+DEPEND="${RDEPEND}
+       dev-ros/cmake_modules
+       test? (
+               dev-cpp/gtest
+               dev-python/nose
+       )"