x11-libs/libX11: Version bump to 1.6.8
authorMatt Turner <mattst88@gentoo.org>
Mon, 17 Jun 2019 14:54:52 +0000 (10:54 -0400)
committerMatt Turner <mattst88@gentoo.org>
Mon, 17 Jun 2019 15:18:51 +0000 (11:18 -0400)
Closes: https://bugs.gentoo.org/299654
Closes: https://bugs.gentoo.org/550502
Closes: https://bugs.gentoo.org/616140
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-libs/libX11/Manifest
x11-libs/libX11/libX11-1.6.8.ebuild [new file with mode: 0644]

index 3c1bb4f9036cc5cb7fdcfc0a705d33f89bc39cc4..7f0eaa3b42c7d1db11862be0cf4c99148ca703ba 100644 (file)
@@ -1 +1,2 @@
 DIST libX11-1.6.7.tar.bz2 2290260 BLAKE2B d149d3eacdb1cd80de378076dd96bbaa2cf0cf24d4431ed1afbc00f6ff43cb5dbbea01345230e8b06cd05900d77d4771a72e3b8c5ddda69cb25c95f02a58d9ce SHA512 edd2273b9dadbbf90ad8d7b5715db29eb120a5a22ad2595f697e56532cc24b84e358580c00548fa6be8e9d26601a2b2cdab32272c59266709534317abbd05cd5
+DIST libX11-1.6.8.tar.bz2 2395911 BLAKE2B 50f8871d7ff2aee14767085a6cf78e9f6e2b01c5143227089590c86db8006836432cb051d6259893850d78d2daea3332a26885a34f07989b869c14b8ddeefa28 SHA512 1de8e0ec466308bc48946d1ce7a7dc6bd3120b1b365cd01afd1bd51dd7369e3d1870dd379b0b7c5b07699095d59761bd23e2e02ab60929de32c39b6885016e76
diff --git a/x11-libs/libX11/libX11-1.6.8.ebuild b/x11-libs/libX11/libX11-1.6.8.ebuild
new file mode 100644 (file)
index 0000000..6cd6825
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-3
+
+DESCRIPTION="X.Org X11 library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="ipv6 test"
+
+RDEPEND=">=x11-libs/libxcb-1.11.1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+       x11-base/xorg-proto
+       x11-libs/xtrans"
+BDEPEND="test? ( dev-lang/perl )"
+
+pkg_setup() {
+       XORG_CONFIGURE_OPTIONS=(
+               $(use_with doc xmlto)
+               $(use_enable doc specs)
+               $(use_enable ipv6)
+               --without-fop
+       )
+}