media-sound/pulseeffects: 3.0.9 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Wed, 29 Nov 2017 04:54:16 +0000 (22:54 -0600)
committerMatthew Thode <prometheanfire@gentoo.org>
Wed, 29 Nov 2017 04:54:39 +0000 (22:54 -0600)
Package-Manager: Portage-2.3.14, Repoman-2.3.6

media-sound/pulseeffects/Manifest
media-sound/pulseeffects/pulseeffects-3.0.9.ebuild [new file with mode: 0644]

index 61ae9377f537f4f6df7bb7cb00305e8b83e00586..3ee302a82ebcae2053e94bb65d1873a50efd45be 100644 (file)
@@ -1 +1,2 @@
 DIST pulseeffects-3.0.8.tar.gz 604530 BLAKE2B e55b08a861f8a9b45191727d000b28b6468d1d46328726ef30f63733bf6b3dd6b745d3f4c38f54c5924950c489c70bb87b57ada4735ce68420d678e93019da65 SHA512 2610b19c0a61510ab9ab29d2fb038a76dcdaf6c168f57d13df8baf32493cf2fe56cfad73f862144117ce511864b405c9d78f294afcab6bc4336ffc234e18110b
+DIST pulseeffects-3.0.9.tar.gz 614347 BLAKE2B ab24d1af31b359348de8de235694100be20cf961c358b63a043670f82efa17afe25b0cf9e723c6be228bd70af2ce0bc91176f6371a549799a4c7921f2fcf7368 SHA512 aad31f042ff1f1e15c50f2a7a63f73b3878fad56101e0fabb51ed2e48500451b401ece8db56c23049ac4455deb481ba0c0586aa9a753581acdb3749a219046f4
diff --git a/media-sound/pulseeffects/pulseeffects-3.0.9.ebuild b/media-sound/pulseeffects/pulseeffects-3.0.9.ebuild
new file mode 100644 (file)
index 0000000..47a858b
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit gnome2-utils meson python-r1
+
+DESCRIPTION="Limiter, compressor, reverberation, equalizer auto volume effects for Pulseaudio"
+HOMEPAGE="https://github.com/wwmm/pulseeffects"
+
+if [[ ${PV} == *9999 ]];then
+       inherit git-r3
+       SRC_URI=""
+       EGIT_REPO_URI="${HOMEPAGE}"
+       KEYWORDS=""
+else
+       SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~x86 ~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       ${PYTHON_DEPS}
+       python_targets_python3_4? ( dev-python/configparser )
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/pygobject:3[${PYTHON_USEDEP}]
+       dev-python/pycairo[${PYTHON_USEDEP}]
+       >=dev-python/gst-python-1.12.0:1.0[${PYTHON_USEDEP}]
+       media-plugins/swh-plugins
+       >=x11-libs/gtk+-3.18:3
+       dev-python/numpy[${PYTHON_USEDEP}]
+       >=sci-libs/scipy-0.18[${PYTHON_USEDEP}]
+       >=media-libs/gstreamer-1.12.0:1.0
+       >=media-libs/gst-plugins-good-1.12.0:1.0
+       >=media-libs/gst-plugins-bad-1.12.0:1.0
+       >=media-plugins/gst-plugins-ladspa-1.12.0:1.0
+       >=media-plugins/gst-plugins-pulse-1.12.0:1.0
+"
+RDEPEND="${DEPEND}
+       media-sound/pulseaudio[equalizer]
+"
+
+pkg_preinst(){
+       gnome2_schemas_savelist
+}
+
+pkg_postinst(){
+       gnome2_gconf_install
+       gnome2_schemas_update
+}
+
+pkg_postrm(){
+       gnome2_gconf_uninstall
+       gnome2_schemas_update
+}