media-video/ffmpeg: Add rubberband useflag.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 14:23:16 +0000 (16:23 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 14:23:22 +0000 (16:23 +0200)
Package-Manager: portage-2.2.21

media-video/ffmpeg/ffmpeg-9999.ebuild
media-video/ffmpeg/metadata.xml

index 8a1727babc115a497ff659ef07af7720e946cb05..394941d149056de8b71fe5673c0caca7bda425b3 100644 (file)
@@ -80,7 +80,7 @@ FFMPEG_FLAG_MAP=(
                zvbi:libzvbi
                # libavfilter options
                bs2b:libbs2b flite:libflite frei0r fribidi:libfribidi fontconfig ladspa
-               libass truetype:libfreetype
+               libass truetype:libfreetype rubberband:librubberband
                # libswresample options
                libsoxr
                # Threads; we only support pthread for now but ffmpeg supports more
@@ -210,6 +210,7 @@ RDEPEND="
        pulseaudio? ( >=media-sound/pulseaudio-2.1-r1[${MULTILIB_USEDEP}] )
        quvi? ( media-libs/libquvi:0.4[${MULTILIB_USEDEP}] )
        librtmp? ( >=media-video/rtmpdump-2.4_p20131018[${MULTILIB_USEDEP}] )
+       rubberband? ( >=media-libs/rubberband-1.8.1-r1[${MULTILIB_USEDEP}] )
        samba? ( >=net-fs/samba-3.6.23-r1[${MULTILIB_USEDEP}] )
        schroedinger? ( >=media-libs/schroedinger-1.0.11-r1[${MULTILIB_USEDEP}] )
        sdl? ( >=media-libs/libsdl-1.2.15-r4[sound,video,${MULTILIB_USEDEP}] )
index dbd3f79f44f428159ebb989e7d4d5d95abcf22b0..ab2aef51409c3c153b9fa8aa95a9cda8b14e9e8b 100644 (file)
@@ -39,6 +39,7 @@
        <flag name="pic">Force shared libraries to be built as PIC (this is slower)</flag>
        <flag name="postproc">Build and install libpostproc.</flag>
        <flag name="quvi">Adds support for playing media from Internet services using the quvi project.</flag>
+       <flag name="rubberband">Adds time-stretching and pitch-shifting audio filter based on <pkg>media-libs/rubberband</pkg>.</flag>
        <flag name="schroedinger">Enable Dirac video support (an advanced royalty-free video compression format) via libschroedinger (high-speed implementation in C of the Dirac codec).</flag>
        <flag name="snappy">Enable <pkg>app-arch/snappy</pkg> support. Required for e.g. Vidvox Hap encoder.</flag>
        <flag name="ssh">Enable SSH/sftp support via <pkg>net-libs/libssh</pkg>.</flag>