app-portage/conf-update: bump to version 1.0.3
authorChema Alonso Josa <nimiux@gentoo.org>
Sat, 29 Aug 2015 12:25:23 +0000 (14:25 +0200)
committerChema Alonso Josa <nimiux@gentoo.org>
Sat, 29 Aug 2015 12:26:05 +0000 (14:26 +0200)
Gentoo-Bug: #527326

Package-Manager: portage-2.2.20.1

app-portage/conf-update/Manifest
app-portage/conf-update/conf-update-1.0.3.ebuild [new file with mode: 0644]

index 76130464779e73711627df5739f189b52361a6f8..4483e2bae8359538bb2ca10d5bf19a3f8dfcf940 100644 (file)
@@ -1 +1,2 @@
 DIST conf-update-1.0.2.tar.bz2 18243 SHA256 1246b83d8927e4333cfcb535217e5f055bc9aa0290f617c2ab1bb97dbeb3de9c SHA512 8611b30e58a9222a024e19d67e957a63d9c44627067a241e4ee5e761f1950ae7f1aa1491f055ba267be65f813ee7da1a8703028736b65dfd2c4ef79ace906f49 WHIRLPOOL 139e07105eed7d8ee5246c24833ecc110c92a5361892a5ee98ea2eee5d30199cbee788f47497d5d32c95c387bbf2df16589faa79c2dbf00b5ca5d347d7483c9e
+DIST conf-update-1.0.3.tar.bz2 18296 SHA256 5b8479447904e809338375c7d586803a3e8f8d6150cfc33da2c83763119a9a54 SHA512 7f20a4974f804d73729105d9abc0f3205a7574c6e2c6dbf020404f3161500b5ecc60d141e0833e9ae0f43a814591a74cd885a5033f50864bbcfb36ba452175b7 WHIRLPOOL e078895290de9cc116847a48c6fd6d190bc9a3700001de6d31a5728a7eefd2bc41bb34b67a3922ef10730f4668415a0b519861152ba4e54fe0150ec01232d578
diff --git a/app-portage/conf-update/conf-update-1.0.3.ebuild b/app-portage/conf-update/conf-update-1.0.3.ebuild
new file mode 100644 (file)
index 0000000..9780031
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="${PN} is a ncurses-based config management utility"
+HOMEPAGE="https://gitweb.gentoo.org/proj/conf-update.git/"
+SRC_URI="https://gitweb.gentoo.org/proj/${PN}.git/snapshot/${PF}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="colordiff"
+
+RDEPEND=">=dev-libs/glib-2.6
+               sys-libs/ncurses:0
+               dev-libs/openssl:0
+               colordiff? ( app-misc/colordiff )"
+DEPEND="virtual/pkgconfig
+               ${RDEPEND}"
+
+src_prepare() {
+       sed -i -e "s/\$Rev:.*\\$/${PVR}/" "${S}"/"${PN}".h || die
+       if use colordiff ; then
+               sed -i -e "s/diff_tool=diff/diff_tool=colordiff/" ${PN}.conf  \ die 'colordiff-sed failed'
+       fi
+       tc-export PKG_CONFIG
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)"
+}