media-libs/qimageblitz: Remove last-rited package
authorAndreas Sturmlechner <asturm@gentoo.org>
Tue, 11 Feb 2020 14:17:00 +0000 (15:17 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Tue, 11 Feb 2020 14:18:21 +0000 (15:18 +0100)
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/qimageblitz/Manifest [deleted file]
media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch [deleted file]
media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch [deleted file]
media-libs/qimageblitz/metadata.xml [deleted file]
media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild [deleted file]
profiles/package.mask

diff --git a/media-libs/qimageblitz/Manifest b/media-libs/qimageblitz/Manifest
deleted file mode 100644 (file)
index a5e6910..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST qimageblitz-0.0.6_p20131029.tar.xz 43428 BLAKE2B 6a10f12236d759cb2999f807ae05345ad91ca2a3f965fa8ae6d38431a4a91439242ceac2facce67b46a5260cef11a4a5fdceccff73260235658830262fc909cc SHA512 2a32105aed52ea33fbd46702a2b7cdd9671efef9bb52209ede534abc95ac40dd9ae2bd22cf09b30a309337653c4a754c50ef3fe4ad0aad7d4ffd0b5994a85981
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-cxx11.patch
deleted file mode 100644 (file)
index da962cd..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt   2017-03-15 00:31:04.000000000 +0100
-+++ b/CMakeLists.txt   2019-07-21 16:39:14.365729343 +0200
-@@ -14,6 +14,8 @@
-   set(CMAKE_AUTOMOC ON)
-   find_package(Qt5Core REQUIRED)
-   find_package(Qt5Gui REQUIRED)
-+  set (CMAKE_CXX_STANDARD 11)
-+  set (CMAKE_CXX_EXTENSIONS OFF)
- else()
-   find_package(Qt4 REQUIRED)
-   # properly set up compile flags (QT_DEBUG/QT_NO_DEBUG, ...)
diff --git a/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch b/media-libs/qimageblitz/files/qimageblitz-0.0.6_p20131029-gcc.patch
deleted file mode 100644 (file)
index 922a262..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/blitz/CMakeLists.txt
-+++ b/blitz/CMakeLists.txt
-@@ -31,12 +31,8 @@
- if(HAVE_MMX)
-     if(NOT APPLE AND NOT WIN32)
-+        enable_language(ASM)
-         set( blitz_LIB_SRCS ${blitz_LIB_SRCS} asm_scale.S )
--        add_custom_command(OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o
--            COMMAND ${CMAKE_C_COMPILER} -c ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S
--            DEPENDS ${CMAKE_CURRENT_SOURCE_DIR}/asm_scale.S )
--        set( blitz_LIB_EXTRA_SRCS ${CMAKE_CURRENT_BINARY_DIR}/asm_scale.o )
--        set(HAVE_EXTERNAL_ASM TRUE)
-     endif(NOT APPLE AND NOT WIN32)
- endif(HAVE_MMX)
- configure_file (config-processor.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config-processor.h )
diff --git a/media-libs/qimageblitz/metadata.xml b/media-libs/qimageblitz/metadata.xml
deleted file mode 100644 (file)
index 0cf5922..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
-       <email>kde@gentoo.org</email>
-       <name>Gentoo KDE Project</name>
-</maintainer>
-</pkgmetadata>
diff --git a/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild b/media-libs/qimageblitz/qimageblitz-0.0.6_p20131029.ebuild
deleted file mode 100644 (file)
index c6a9d62..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Graphical effect and filter library by KDE"
-HOMEPAGE="https://websvn.kde.org/trunk/kdesupport/qimageblitz/"
-SRC_URI="https://dev.gentoo.org/~asturm/distfiles/${P}.tar.xz"
-
-LICENSE="GPL-2 LGPL-2"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-SLOT="0"
-IUSE="altivec cpu_flags_x86_3dnow cpu_flags_x86_mmx cpu_flags_x86_sse cpu_flags_x86_sse2 debug"
-
-DEPEND="
-       dev-qt/qtcore:5
-       dev-qt/qtgui:5
-       dev-qt/qtwidgets:5
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
-       "${FILESDIR}/${P}-gcc.patch"
-       "${FILESDIR}/${P}-cxx11.patch" # bug 690360
-)
-
-src_configure() {
-       local mycmakeargs=(
-               -DQT4_BUILD=OFF
-               -DHAVE_3DNOW=$(usex cpu_flags_x86_3dnow)
-               -DHAVE_MMX=$(usex cpu_flags_x86_mmx)
-               -DHAVE_SSE=$(usex cpu_flags_x86_sse)
-               -DHAVE_SSE2=$(usex cpu_flags_x86_sse2)
-       )
-       use ppc && mycmakeargs+=( -DHAVE_ALTIVEC=$(usex altivec) )
-
-       cmake_src_configure
-}
index 08158afc6458eb2074d4c08bb72dd21ea08e2c09..6a2c9fa5ca9b2081c87f95cd51dadb63811054a4 100644 (file)
@@ -590,7 +590,6 @@ media-plugins/vdr-mailbox
 # Unmaintained upstream and redundant. Use kde-apps/kamera instead.
 # Only revdep of ancient media-libs/qimageblitz. Removal in 30 days.
 media-video/kamerka
-media-libs/qimageblitz
 
 # Michał Górny <mgorny@gentoo.org> (2020-01-12)
 # Python 2 only, depends on OpenStack which is Py3 now.  No release