dev-python/urwidtrees: Bump version
authorAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 29 May 2017 08:45:16 +0000 (09:45 +0100)
committerAmadeusz Żołnowski <aidecoe@gentoo.org>
Mon, 29 May 2017 11:49:13 +0000 (12:49 +0100)
Sources URI has changed from PyPI to GitHub.

Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-python/urwidtrees/Manifest
dev-python/urwidtrees/urwidtrees-1.0.2.ebuild [new file with mode: 0644]

index 9e75ffbf4525467c556d220119641bd4bc50d12b..d601d8b05d7580988339bb94048b37ad638a84e2 100644 (file)
@@ -1 +1,2 @@
 DIST urwidtrees-1.0.1.1.tar.gz 12916 SHA256 08a66d0e76e94bc32bc590e35ed283e8a6b0c93adeb431dc576ec0a345f09bfd SHA512 9494cc3c4fe72b468443bbaef0d95f5288ed0dc3a8be00a3bbc261b9b3c4a3752df2f89e439082ed91ba89790c5ad656850d874b5e934cc5a23e87eea8fe4df0 WHIRLPOOL 929d69e4e05fb8e1d68263948b46be5fdc55c480e2678d59d85fa05bd68f795979d97c4fab3f6c8e5d74a71c2375d4805d19f4d44e3def87750dfaad2bdee192
+DIST urwidtrees-1.0.2.tar.gz 36082 SHA256 703f4b161b930a26a461a3e3e695f94237ac75e2a52b87613e49093d9aa76034 SHA512 535b99d91154c308260a0ee6490868724ce8dfa89acf3b623c08409ec6e15194d9e94085411dd7796cad98865ed57692a88cbc11540e6523fc371eaf0204ac17 WHIRLPOOL 1ed3afe730855405332afa5813749e6b6400b1accf776d80f4b9a8e98a0d63fa822e7ee4ec4fc81d55f06364447d741f6e473b7eee729229667ea65404abe9c5
diff --git a/dev-python/urwidtrees/urwidtrees-1.0.2.ebuild b/dev-python/urwidtrees/urwidtrees-1.0.2.ebuild
new file mode 100644 (file)
index 0000000..26a98d8
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Tree widgets for urwid"
+HOMEPAGE="https://github.com/pazz/urwidtrees"
+#SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/pazz/urwidtrees/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/urwid-1.1.0[${PYTHON_USEDEP}]"
+
+src_prepare() {
+       find "${S}" -name '*.py' -print0 | xargs -0 -- sed \
+               -e '1i# -*- coding: utf-8 -*-' -i || die
+
+       distutils-r1_src_prepare
+
+       local md
+       for md in *.md; do
+               mv "${md}" "${md%.md}"
+       done
+}
+
+src_compile() {
+       distutils-r1_src_compile
+
+       if use doc; then
+               pushd docs || die
+               emake html
+               popd || die
+       fi
+}
+
+src_install() {
+       distutils-r1_src_install
+
+       if use doc; then
+               dohtml -r docs/build/html/*
+       fi
+}