dev-libs/libinput: Version bump
authorManuel Rüger <mrueg@gentoo.org>
Wed, 26 Aug 2015 08:57:33 +0000 (10:57 +0200)
committerManuel Rüger <mrueg@gentoo.org>
Wed, 26 Aug 2015 08:58:08 +0000 (10:58 +0200)
Package-Manager: portage-2.2.20.1

dev-libs/libinput/Manifest
dev-libs/libinput/libinput-1.0.0.ebuild [new file with mode: 0644]

index 32b187b16223f4d6615af88d91dfce178b5c4ea3..7bec1ba0c214c25f1038dd80e966f6b7abab0ea8 100644 (file)
@@ -5,3 +5,4 @@ DIST libinput-0.20.0.tar.xz 647668 SHA256 175bdfce97cfab13a2a0d02c3138fcf02f60c8
 DIST libinput-0.21.0.tar.xz 658788 SHA256 7cce7a9e510dfe5c4a19ad00e9350808d4f59f8611fd2b5e87213c507283f550 SHA512 676d5353ca9fb6b6a3f76f4e2d2ab4c78b09240c0bba5d4e06049e2f6fc913ed99cdc60880d00d34c2f3367937e3fca03f0d3d8baaf3d3348d4f2edba1b600a5 WHIRLPOOL a6367e7edc797292937bc956d3ed6c2d73987f058d4eeddc43436115f8674ba1ff558ca9f7b5b6d56420fe64210565d47fae9dfe188b8ebedc91d2b991901721
 DIST libinput-0.7.0.tar.xz 440228 SHA256 129f485afe5e4a9394641293991c97cb99f5f3338340d0d65b704ff463d1579e SHA512 0e03ab7ca98c4574997742b7d8912000fb176d7a3e2c381b7e63139f78455374f8f38284e226fe443d5a524f34be8995317b91fc0190795a97b10af060423b77 WHIRLPOOL 664510fc33cb718b56600553332bb3eb587b3f4a40f81d4a80dd218882aba204522bcbbfab98f3ae0c6447d3a39cc98b9d88aea5f8e3c21da0803b93d64ad321
 DIST libinput-0.9.0.tar.xz 510512 SHA256 309043976f41f5451c2a4b1c25bc2993b18aecb22524d797f21eb6b6c968ff0d SHA512 a6f718215428eda45ac00c25d0b62ada84bf924822cb66e0a9b28f4cfc36e7d1678f2dfb47afae16ce4c277d589adcf97aefe8e2e5a154873b649fe4a84527a1 WHIRLPOOL 23da6dbcd7b17000cea641e0931db8a9b2ad34b0655e4e31b0419ff4799adc59d2646b10316e073ad49695ebd652c150abf05c39d15c735ecb1d97f6f8c1d8de
+DIST libinput-1.0.0.tar.xz 785056 SHA256 afbd2751c000a4e5833624b6177a6919ad259f0bca44093947421c885fd42c0f SHA512 b6fc7973982cb2826fc5beb514e954d7673023628739a86d18b2522b1ad0ecf55f9d6c83e6307c10c633c57d6b61227898aded6a22a2de536c0f14f27d23b903 WHIRLPOOL 13304875b753127ada76bf18ba56ea9828d6532db5eefce56439ede83eeeb43b6da6aa59f763d2c912de838221ee53fd7d02bf865e80316a24c412ea001d3043
diff --git a/dev-libs/libinput/libinput-1.0.0.ebuild b/dev-libs/libinput/libinput-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..b4ddf6c
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="http://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+       >=dev-libs/libevdev-0.4
+       >=sys-libs/mtdev-1.1
+       virtual/libudev"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+#      test? (
+#              >=dev-libs/check-0.9.10
+#              dev-util/valgrind
+#              sys-libs/libunwind )
+
+src_configure() {
+       # Doc handling in kinda strange but everything
+       # is available in the tarball already.
+       sed -e 's/^\(SUBDIRS =.*\)doc\(.*\)$/\1\2/' \
+               -i Makefile.am Makefile.in || die
+}
+
+src_configure() {
+       # gui can be built but will not be installed
+       # building documentation silently fails with graphviz syntax errors
+       econf \
+               --disable-documentation \
+               --disable-event-gui \
+               $(use_enable test tests) \
+               --with-udev-dir="$(get_udevdir)"
+}
+
+src_install() {
+       emake install DESTDIR="${D}"
+       dodoc -r doc/html
+       prune_libtool_files
+}