media-fonts/encodings: Version bump to 1.0.5
authorMatt Turner <mattst88@gentoo.org>
Mon, 17 Jun 2019 17:00:26 +0000 (13:00 -0400)
committerMatt Turner <mattst88@gentoo.org>
Mon, 17 Jun 2019 17:14:49 +0000 (13:14 -0400)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-fonts/encodings/Manifest
media-fonts/encodings/encodings-1.0.5.ebuild [new file with mode: 0644]

index 0142e95c9b1548d5ddd7dd241628c8c07dd730fe..8afc49aa643d7bee9b03299baa76b1f4058f4a2e 100644 (file)
@@ -1 +1,2 @@
 DIST encodings-1.0.4.tar.bz2 665087 BLAKE2B 867da2247836ed829af8e6c465eeeb40e84d98bd114939843be619f2915f61c5ffc56a48adf9414e39c7a3ddd0fc86572fb85d2bc486cf68886d48d78e369761 SHA512 838d1c9489e9880bf1982dc14d34a48b624b7bc2c0fffbf28e2c24e1546b0602357ca31afef100053481d6a18e357085ef74ac7a82261daa1ac1398bc1e05d17
+DIST encodings-1.0.5.tar.bz2 713817 BLAKE2B 43e466c27fdf485e9704debb89c69a3c3eaecf84453362d86b53aa9c33d10b8f97f348ef35f8b430be101e8281ecce5d5f49a052929fc7cd37d94a7590645193 SHA512 920e49f0b3545f181a1574ca3280ac9adef1e68fe27566c195dd7013f728d355c0d759132789357fcf8fa7391fcbe1e17edf2bd85aa5611df5a4d99740011008
diff --git a/media-fonts/encodings/encodings-1.0.5.ebuild b/media-fonts/encodings/encodings-1.0.5.ebuild
new file mode 100644 (file)
index 0000000..5bb3b27
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# font eclass is inherited directly, since this package is a special case that
+# would greatly complicate the fonts logic of xorg-2
+inherit font xorg-2
+
+DESCRIPTION="X.Org font encodings"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="x11-apps/mkfontscale
+       >=media-fonts/font-util-1.1.1-r1"
+
+pkg_postinst() {
+       xorg-2_pkg_postinst
+       font_pkg_postinst
+}
+
+pkg_postrm() {
+       xorg-2_pkg_postrm
+       font_pkg_postrm
+}