app-leechcraft/lc-bittorrent: update geoip dep, bump EAPI
author0xd34df00d <0xd34df00d@gmail.com>
Tue, 31 Mar 2020 19:59:23 +0000 (15:59 -0400)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 5 Apr 2020 19:47:15 +0000 (21:47 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Georg Rudoy <0xd34df00d@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/15190
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
app-leechcraft/lc-bittorrent/lc-bittorrent-9999.ebuild

index aadccf015c70596b80a46ef749855c01db1f86ab..7ac2ceed98f57ededed1deff2087049d1b30c145 100644 (file)
@@ -1,7 +1,7 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
 inherit leechcraft
 
@@ -13,18 +13,18 @@ IUSE="debug geoip"
 
 DEPEND="
        ~app-leechcraft/lc-core-${PV}
-       net-libs/libtorrent-rasterbar
-       dev-qt/qtxml:5
        dev-qt/qtwidgets:5
+       dev-qt/qtxml:5
+       net-libs/libtorrent-rasterbar:=
+       geoip? ( dev-libs/libmaxminddb:= )
 "
 RDEPEND="${DEPEND}
        virtual/leechcraft-task-show
-       geoip? ( dev-libs/geoip )
 "
 
 src_configure() {
        local mycmakeargs=(
                -DENABLE_BITTORRENT_GEOIP=$(usex geoip)
        )
-       cmake-utils_src_configure
+       cmake_src_configure
 }