games-fps/freedoom: Add doom engine runtime dependency
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>
Sun, 9 Jun 2019 02:55:09 +0000 (11:55 +0900)
committerJames Le Cuirot <chewi@gentoo.org>
Tue, 18 Jun 2019 21:20:38 +0000 (22:20 +0100)
Freedoom is distributed by upstream with the intention to be run by a
doom engine; this is also the expectation of end users. This patch adds
a doom engine as a runtime dependency for Freedoom.

Three possible doom engines are listed in RDEPEND: games-engines/odamex,
games-fps/doomsday, games-fps/gzdoom. The games-fps/gzdoom package is
set to preferred as it is the recommendation of the Freedoom upstream
team.

Closes: https://bugs.gentoo.org/687672
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com>
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-fps/freedoom/freedoom-0.11.3-r1.ebuild [new file with mode: 0644]

diff --git a/games-fps/freedoom/freedoom-0.11.3-r1.ebuild b/games-fps/freedoom/freedoom-0.11.3-r1.ebuild
new file mode 100644 (file)
index 0000000..2f5fd2f
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A complete free-content single-player focused game based on the Doom engine"
+HOMEPAGE="https://freedoom.github.io"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       ~games-fps/freedoom-data-${PV}
+       || (
+               games-fps/gzdoom
+               games-engines/odamex
+               games-fps/doomsday
+       )
+"
+
+pkg_postinst() {
+       elog "If you are looking for a multiplayer-focused deathmatch game, please install games-fps/freedm."
+}