x11-misc/xtrlock: Version 2.13
authorJeroen Roovers <jer@gentoo.org>
Wed, 1 Apr 2020 06:09:00 +0000 (08:09 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 1 Apr 2020 06:09:27 +0000 (08:09 +0200)
Package-Manager: Portage-2.3.96, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/xtrlock/Manifest
x11-misc/xtrlock/xtrlock-2.13.ebuild [new file with mode: 0644]

index 526864a09296df0b9034e7f2530c81bb1bc5b02e..dc098a88c16a8647d12a3aea8baf5462d0e59b7d 100644 (file)
@@ -1 +1,2 @@
 DIST xtrlock_2.12.tar.xz 20620 BLAKE2B d40599f5fec67b8e89f1028dafc929a9b21d6ae1f6e094658d07859e7f74e4686d338e1e03393f9981a62030839969b57493a8655e225b963df8dc04cf6b62f6 SHA512 8392a8c254726e99d2324415bfdac6e577f725942d4e7fd39c915637f87814f1737aefa903a1502632272cabbb10182070dc15ec5d3e5268c9c1b53218d00f36
+DIST xtrlock_2.13.tar.xz 21156 BLAKE2B 879c27936cf8058707cbdb2247e1044c8c5eadf74dcb2bcfd5ec8f4b2bab80da6859118e48943de97f7696e41456771bf274b03728a61f5ac6bef8b471192dce SHA512 656e1e77194b816b04260a88c8046b8ef25d6df0405de6fe1ee1dfb2ebfa528a329c1b67be70eaac5ce4ee6a4159d728d363bf8a59232941b76b1e6d14aa91aa
diff --git a/x11-misc/xtrlock/xtrlock-2.13.ebuild b/x11-misc/xtrlock/xtrlock-2.13.ebuild
new file mode 100644 (file)
index 0000000..87544ef
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A simplistic screen locking program for X"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/x/xtrlock/"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${P/-/_}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+       x11-libs/libX11
+"
+DEPEND="
+       ${RDEPEND}
+       x11-base/xorg-proto
+       x11-misc/imake
+"
+
+src_compile() {
+       xmkmf || die
+       emake CDEBUGFLAGS="${CFLAGS} -DSHADOW_PWD" CC="$(tc-getCC)" \
+               EXTRA_LDOPTIONS="${LDFLAGS}" xtrlock
+}
+
+src_install() {
+       dobin xtrlock
+       chmod u+s "${D}"/usr/bin/xtrlock
+       newman xtrlock.man xtrlock.1
+       dodoc debian/changelog
+}