dev-python/async_generator: Enable Python 3.7
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 08:10:34 +0000 (10:10 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 12:26:05 +0000 (14:26 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/async_generator/async_generator-1.10.ebuild

index 7e17bf06efda1214924b39d354d3ac190d19a2f0..c21b9a6072b9fc95de8d10a39ded103da0c166a3 100644 (file)
@@ -1,24 +1,26 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_{5,6,7} )
 
 inherit distutils-r1
 
 DESCRIPTION="Making it easy to write async iterators in Python 3.5"
 HOMEPAGE="https://github.com/python-trio/async_generator https://pypi.org/project/async_generator/"
 SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
 LICENSE="|| ( MIT Apache-2.0 )"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~x86"
 IUSE="test"
+
 DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
        test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
 
 DOCS=( README.rst )
 
 python_test() {
-       py.test -v || die "tests failed under ${EPYTHON}"
+       pytest -vv || die "tests failed under ${EPYTHON}"
 }