dev-php/pecl-ssh2: Drop 5.5 support on 0.13 and allow easier 7.0 transition
authorBrian Evans <grknight@gentoo.org>
Wed, 7 Dec 2016 14:17:54 +0000 (09:17 -0500)
committerBrian Evans <grknight@gentoo.org>
Wed, 7 Dec 2016 15:04:50 +0000 (10:04 -0500)
Package-Manager: portage-2.3.2

dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild [new file with mode: 0644]

diff --git a/dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-0.13-r1.ebuild
new file mode 100644 (file)
index 0000000..8a1cea7
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="ssh2"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php7-0 php5-6"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+
+DESCRIPTION="PHP bindings for the libssh2 library"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+DEPEND=">=net-libs/libssh2-1.2"
+RDEPEND="${DEPEND}"
+PHP_EXT_ECONF_ARGS=""
+PDEPEND="php_targets_php7-0? ( dev-php/pecl-ssh2:7 )"
+
+src_prepare(){
+       if use php_targets_php5-6 ; then
+               php-ext-source-r3_src_prepare
+       else
+               default_src_prepare
+       fi
+}