Version bump. Watch out for the configuration file changes!
authorHenrik Brix Andersen <brix@gentoo.org>
Mon, 5 Jun 2006 11:44:08 +0000 (11:44 +0000)
committerHenrik Brix Andersen <brix@gentoo.org>
Mon, 5 Jun 2006 11:44:08 +0000 (11:44 +0000)
Package-Manager: portage-2.0.54-r2

sys-power/hibernate-script/ChangeLog
sys-power/hibernate-script/Manifest
sys-power/hibernate-script/files/digest-hibernate-script-1.91 [new file with mode: 0644]
sys-power/hibernate-script/files/hibernate-script-1.91-gentoo.patch [new file with mode: 0644]
sys-power/hibernate-script/hibernate-script-1.91.ebuild [new file with mode: 0644]

index e8f29590dc1bd3aac75655674572f65023ef9839..8d84a5c2744323dbd5ae1e485254cd9f826569cb 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-power/hibernate-script
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.23 2006/05/28 12:26:44 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.24 2006/06/05 11:44:08 brix Exp $
+
+*hibernate-script-1.91 (05 Jun 2006)
+
+  05 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+  +files/hibernate-script-1.91-gentoo.patch, +hibernate-script-1.91.ebuild:
+  Version bump. Watch out for the configuration file changes!
 
   28 May 2006; Henrik Brix Andersen <brix@gentoo.org>
   -hibernate-script-1.12.ebuild:
index fbaebad39f12df33f6c714dca1182941d25d2ba4..41552f691b10ca76245283dbaa952285703a977c 100644 (file)
@@ -1,6 +1,9 @@
-MD5 fed710448ed45866fa9a3ccea7927791 ChangeLog 5432
+MD5 22a953e4b16f1c852d9cc024e62ecfa3 ChangeLog 5663
 MD5 2875fd3dd88aa57c273a8227244675ef files/digest-hibernate-script-1.12-r1 72
+MD5 3226a34c958123a27378a2d9e0178de7 files/digest-hibernate-script-1.91 72
 MD5 4771f1307f9d9d0d08fdfa6b4de5af48 files/hibernate-script-1.12-gentoo.patch 834
 MD5 296333753a66d9b42c6a1f25b2c432f3 files/hibernate-script-1.12-misc.patch 522
+MD5 4771f1307f9d9d0d08fdfa6b4de5af48 files/hibernate-script-1.91-gentoo.patch 834
 MD5 53831bcba1472acf2c180f2e6e754a63 hibernate-script-1.12-r1.ebuild 1974
+MD5 9f8043f7a55fe38ebe5f1ad94c8dadd5 hibernate-script-1.91.ebuild 2114
 MD5 b280eebc74d70d85e664debf1adce2c3 metadata.xml 255
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.91 b/sys-power/hibernate-script/files/digest-hibernate-script-1.91
new file mode 100644 (file)
index 0000000..529920c
--- /dev/null
@@ -0,0 +1 @@
+MD5 f3c5275dd6053dc6423eb27032c81d4c hibernate-script-1.91.tar.gz 67112
diff --git a/sys-power/hibernate-script/files/hibernate-script-1.91-gentoo.patch b/sys-power/hibernate-script/files/hibernate-script-1.91-gentoo.patch
new file mode 100644 (file)
index 0000000..2816289
--- /dev/null
@@ -0,0 +1,29 @@
+diff -urp hibernate-script-1.12/init.d/hibernate-cleanup.sh hibernate-script-1.12-gentoo/init.d/hibernate-cleanup.sh
+--- hibernate-script-1.12/init.d/hibernate-cleanup.sh  2005-10-02 07:54:23.000000000 +0200
++++ hibernate-script-1.12-gentoo/init.d/hibernate-cleanup.sh   2005-10-20 15:31:33.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#!/sbin/runscript
+ # This script invalidates any stale swsusp and Software Suspend 2 images. It
+ # searches all swap partitions on your machine, as well as Suspend2's
+@@ -66,9 +66,14 @@ check_filewriter_sig() {
+       esac
+ }
+-echo -n "Clearing Software Suspend 2 signatures... "
+-check_swap_sig
+-check_filewriter_sig
+-echo "done."
++depend() {
++      after localmount
++      before bootmisc
++}
+-exit 0
++start() {
++      ebegin "Clearing Software Suspend signatures"
++      check_swap_sig
++      check_filewriter_sig
++      eend
++}
diff --git a/sys-power/hibernate-script/hibernate-script-1.91.ebuild b/sys-power/hibernate-script/hibernate-script-1.91.ebuild
new file mode 100644 (file)
index 0000000..09adae2
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.91.ebuild,v 1.1 2006/06/05 11:44:08 brix Exp $
+
+inherit eutils
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+       unpack ${A}
+
+       cd ${S}
+       epatch ${FILESDIR}/${P}-gentoo.patch
+
+       # remove obsolete swsusp2_15 scriptlet
+       rm -f ${S}/scriptlets.d/swsusp2_15
+
+       sed -i \
+               -e "s:^# \(Distribution\).*:\1 gentoo:" \
+               ${S}/common.conf
+
+       sed -i \
+               -e "s:/usr/local::" \
+               ${S}/suspend2.conf
+}
+
+src_install() {
+       BASE_DIR=${D} PREFIX=/usr MAN_DIR=${D}/usr/share/man \
+               ${S}/install.sh
+
+       # hibernate-ram will default to using ram.conf
+       dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+       newinitd ${S}/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+       # other ebuilds can install scriplets to this dir
+       keepdir /etc/hibernate/scriptlets.d/
+
+       if use vim; then
+               insinto /usr/share/vim/vimfiles
+               doins hibernate.vim
+       fi
+
+       dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+       if use logrotate; then
+               insinto /etc/logrotate.d
+               newins logrotate.d-hibernate-script hibernate-script
+       fi
+}
+
+pkg_postinst() {
+       einfo
+       einfo "You should run the following command to invalidate"
+       einfo "suspend images on a clean boot."
+       einfo
+       einfo "  # rc-update add hibernate-cleanup boot"
+       einfo
+       einfo "See /usr/share/doc/${PF}/README.gz for further details."
+       einfo
+       einfo "Please note that you will need to manually emerge any utilities"
+       einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+       einfo "should you wish to use them."
+       einfo
+       einfo "Starting with hibernate-script-1.90 the configuration files have"
+       einfo "been reordered and split into method specific files. Make sure you"
+       einfo "update your /etc/hibernate/ configuration files accordingly."
+       einfo
+}