sys-block/fio: delete wrong arch USE flag checking
authorMike Frysinger <vapier@gentoo.org>
Thu, 1 Oct 2015 03:18:01 +0000 (23:18 -0400)
committerMike Frysinger <vapier@gentoo.org>
Thu, 1 Oct 2015 03:18:01 +0000 (23:18 -0400)
USE flags that are not available for an arch should be masked in their
profile, not have ad-hoc checks in ebuilds.  Since the arm profile was
updated at some point to mask USE=glusterfs, we can drop the wrong code
in these ebuilds.

sys-block/fio/fio-2.2.10.ebuild
sys-block/fio/fio-2.2.4-r1.ebuild
sys-block/fio/fio-2.2.9.ebuild

index dd22e17edae88f81f4312a76405c0b16b7704a90..82955436697f1e6eb155c5493bf11ca031c5674f 100644 (file)
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
 IUSE="aio glusterfs gnuplot gtk numa rbd rdma static zlib"
 
 DEPEND="aio? ( dev-libs/libaio )
-       glusterfs? ( !arm? ( sys-cluster/glusterfs ) )
+       glusterfs? ( sys-cluster/glusterfs )
        gtk? (
                dev-libs/glib:2
                x11-libs/gtk+:2
index 7294045a024eec748c5cb772a5f2f9a40db72b60..d645612bb4dcb66bc1a84d32f536e4ac0f653311 100644 (file)
@@ -19,7 +19,7 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
 IUSE="aio glusterfs gnuplot gtk numa rbd rdma zlib"
 
 DEPEND="aio? ( dev-libs/libaio )
-       glusterfs? ( !arm? ( sys-cluster/glusterfs ) )
+       glusterfs? ( sys-cluster/glusterfs )
        gtk? (
                dev-libs/glib:2
                x11-libs/gtk+:2
index 7e5e76332f5047d31570e30b406864c4eaf4eae0..e9421a2b9f1524403dd09d9004ec32c20e797d2a 100644 (file)
@@ -19,7 +19,7 @@ KEYWORDS="amd64 ~arm ~ia64 ~ppc ~ppc64 x86"
 IUSE="aio glusterfs gnuplot gtk numa rbd rdma static zlib"
 
 DEPEND="aio? ( dev-libs/libaio )
-       glusterfs? ( !arm? ( sys-cluster/glusterfs ) )
+       glusterfs? ( sys-cluster/glusterfs )
        gtk? (
                dev-libs/glib:2
                x11-libs/gtk+:2