x11-misc/wbar: Fix automagic dev-libs/glib dependency
authorJeroen Roovers <jer@gentoo.org>
Thu, 9 May 2019 07:48:35 +0000 (09:48 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 9 May 2019 08:03:59 +0000 (10:03 +0200)
* Fix a bunch of C++11 warnings
* USE=-gtk should patch out AM_GLIB_GNU_GETTEXT and @INTLLIBS@
* USE=gtk should depend on dev-libs/glib

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Fixes: https://bugs.gentoo.org/685068
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
x11-misc/wbar/files/wbar-2.3.4-c++11.patch [new file with mode: 0644]
x11-misc/wbar/files/wbar-2.3.4-gtk.patch [new file with mode: 0644]
x11-misc/wbar/wbar-2.3.4-r3.ebuild [new file with mode: 0644]

diff --git a/x11-misc/wbar/files/wbar-2.3.4-c++11.patch b/x11-misc/wbar/files/wbar-2.3.4-c++11.patch
new file mode 100644 (file)
index 0000000..fead9e9
--- /dev/null
@@ -0,0 +1,54 @@
+--- a/src/config/Functions.cc
++++ b/src/config/Functions.cc
+@@ -11,7 +11,7 @@
+ #include "Run.h"
+ #include "OptParser.h"
+-#define ICON_DEFAULT PIXMAPDIR"/"PACKAGE_NAME".png"
++#define ICON_DEFAULT PIXMAPDIR "/" PACKAGE_NAME ".png"
+ static const gchar *authors[] =
+ {
+@@ -304,7 +304,7 @@
+         
+         if (command.empty())
+         {
+-            command = PACKAGE_NAME" "DEFAULT_ARGV;
++            command = PACKAGE_NAME " " DEFAULT_ARGV;
+         }
+         if (argc <= 1 || tmpoptparser.isSet( OptParser::CONFIG ))
+--- a/src/config/Run.cc
++++ b/src/config/Run.cc
+@@ -125,9 +125,9 @@
+ bool Run::start(std::string command)
+ {
+-    if (system ((PACKAGE_NAME" " + command + " &").c_str()) != 0)
++    if (system ((PACKAGE_NAME " " + command + " &").c_str()) != 0)
+     {
+-        std::cout << _("Error run program: ") << PACKAGE_NAME" " + command << std::endl;
++        std::cout << _("Error run program: ") << PACKAGE_NAME " " + command << std::endl;
+     }
+     return Run::getPID() > 0;
+ }
+@@ -136,7 +136,7 @@
+ {
+     if (Run::getPID() > 0)
+     {
+-        if (system ("killall "PACKAGE_NAME) != 0)
++        if (system ("killall " PACKAGE_NAME) != 0)
+         {
+             std::cout << _("Error kill program: ") << PACKAGE_NAME << std::endl;
+         }
+--- a/src/core/Main.cc
++++ b/src/core/Main.cc
+@@ -81,7 +81,7 @@
+         if (command.empty())
+         {
+-            command = PACKAGE_NAME" "DEFAULT_ARGV;
++            command = PACKAGE_NAME " " DEFAULT_ARGV;
+         }
+         if (argc <= 1 || tmpoptparser.isSet( OptParser::CONFIG ))
diff --git a/x11-misc/wbar/files/wbar-2.3.4-gtk.patch b/x11-misc/wbar/files/wbar-2.3.4-gtk.patch
new file mode 100644 (file)
index 0000000..76f2b90
--- /dev/null
@@ -0,0 +1,32 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -59,7 +59,6 @@
+ AC_DEFINE_UNQUOTED(DEFAULT_ARGV, "$DEFAULT_ARGV" , [ The default argv ])
+ AC_PROG_INTLTOOL()
+-AM_GLIB_GNU_GETTEXT
+ PKG_PROG_PKG_CONFIG
+ PKG_CHECK_MODULES(modules, [imlib2 x11])
+--- a/etc/wbar.cfg.in
++++ b/etc/wbar.cfg.in
+@@ -2,8 +2,3 @@
+ c: @PACKAGE_NAME@ @DEFAULT_ARGV@
+ t: none
+-i: @PIXMAPDIR@/@PACKAGE_NAME@/wbar.png
+-c: wbar-config
+-t: Config
+-
+-
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -51,7 +51,7 @@
+ $(top_srcdir)/src/utils/i18n.h
+ wbar_CXXFLAGS = @modules_CFLAGS@
+-wbar_LDADD = @modules_LIBS@ @INTLLIBS@
++wbar_LDADD = @modules_LIBS@ 
+ if WBAR_CONFIG
+ wbar_config_CXXFLAGS = @gui_modules_CFLAGS@
diff --git a/x11-misc/wbar/wbar-2.3.4-r3.ebuild b/x11-misc/wbar/wbar-2.3.4-r3.ebuild
new file mode 100644 (file)
index 0000000..f46e060
--- /dev/null
@@ -0,0 +1,57 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools bash-completion-r1
+
+DESCRIPTION="A fast, lightweight quick launch bar"
+HOMEPAGE="https://github.com/rodolf0/wbar"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="gtk"
+RDEPEND="
+       media-libs/imlib2[X]
+       x11-libs/libX11
+       gtk? (
+               dev-libs/glib
+               gnome-base/libglade
+               media-libs/freetype:2
+               x11-libs/gdk-pixbuf:2
+               x11-libs/gtk+:2
+       )
+"
+DEPEND="
+       ${RDEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+"
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.3.3-desktopfile.patch
+       "${FILESDIR}"/${PN}-2.3.3-nowerror.patch
+       "${FILESDIR}"/${PN}-2.3.3-test.patch
+       "${FILESDIR}"/${PN}-2.3.4-automake-1.13.patch
+       "${FILESDIR}"/${PN}-2.3.4-c++11.patch
+       "${FILESDIR}"/${PN}-2.3.4-completion.patch
+)
+
+src_prepare() {
+       default
+
+       use gtk || eapply "${FILESDIR}"/${PN}-2.3.4-gtk.patch
+
+       sed -i \
+               -e "/^bashcompletiondir/s:=.*$:=$(get_bashcompdir):" \
+               etc/Makefile.am || die #482358
+
+       eautoreconf
+}
+
+src_configure() {
+       econf \
+               $(use_enable gtk wbar-config)
+}