dev-python/google-apitools: Bump to 0.5.31
authorMichał Górny <mgorny@gentoo.org>
Fri, 15 May 2020 06:45:49 +0000 (08:45 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 15 May 2020 06:56:23 +0000 (08:56 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/google-apitools/Manifest
dev-python/google-apitools/google-apitools-0.5.31.ebuild [new file with mode: 0644]

index 3694ed735d811ab4478fb80baffb9c10ef48d842..ce359493041d0974cee77c3527c46624d491b489 100644 (file)
@@ -1 +1,2 @@
 DIST google-apitools-0.5.30_p20200507.tar.gz 365250 BLAKE2B 58d52016775b387b494d8b5897886f059fe74a360098f6527089039469d4d4e3c0d9ec63a12be1215741fd15a1a03e2204f54ace7c9eaf8bbdc8236c9c1fe576 SHA512 94879360c5de3d7405b7377b2baf0fa303c1b0bace56cf75d203b0a509ac028e1d3208a82ba08de7d17e4e26571c9b8601cb07e6897b658eeede9d06fd384fe3
+DIST google-apitools-0.5.31.tar.gz 364797 BLAKE2B f61ea1f982653998d9c85782f171f1bbb5f1c20dee067eb5b865d4eb87db8287544aeeb94f722f8cd1d04c45974c15c54ec7edd581287323c9336d11e642f1b6 SHA512 b66b4ee17dca9330c036ad93521ec76ece84b2780743486e58f768db8949875710af256fe6ba8e570c1309b791c0fc0d6fca84342e3ced85fc6fba416cd849e1
diff --git a/dev-python/google-apitools/google-apitools-0.5.31.ebuild b/dev-python/google-apitools/google-apitools-0.5.31.ebuild
new file mode 100644 (file)
index 0000000..1056f05
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="Python library to manipulate Google APIs"
+HOMEPAGE="https://github.com/google/apitools"
+SRC_URI="https://github.com/google/apitools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/apitools-${PV}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-python/httplib2-0.8[${PYTHON_USEDEP}]
+       >=dev-python/fasteners-0.14[${PYTHON_USEDEP}]
+       >=dev-python/oauth2client-1.5.2[${PYTHON_USEDEP}]
+       >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
+       >=dev-python/python-gflags-3.1.2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-18.5[${PYTHON_USEDEP}]
+       test? ( >=dev-python/mock-1.0.1[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests nose