dev-python/keyring: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:20:17 +0000 (13:20 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:20:17 +0000 (13:20 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/keyring/Manifest
dev-python/keyring/keyring-19.2.0.ebuild [deleted file]

index 0c5d7675ef42ce8656e68817ff15860eb3017c30..ddf875dc99e0df66b67ed801d92495049aeed463 100644 (file)
@@ -1,2 +1 @@
-DIST keyring-19.2.0.tar.gz 41728 BLAKE2B 24a8f095f4009f37fa6d5e7bc2b12be816a5db2abfa4416fc18203a818296c775fe34a2936a71b191700ad511e01059974aec374aea5ee312507a27bd8be76b8 SHA512 5104423289b9e537e64760afed38e5851766b9c955c0659b078cdaba82813e93922e488b5465157cb930285416feef07c0b559fc49909f58bc85b6f30d55dd75
 DIST keyring-19.3.0.tar.gz 43587 BLAKE2B a1003aa55ac48f39e84431c50fe3e24e1da76a0db177eed08bd2c2110b78d10cbfcf7188519435732be68452a0318119cca1563168410b16fc529a3a7e98125c SHA512 b1d26f665203b11712ef91057ecd78cce58b35038b259605c42997283f6c41449baf242ecf43510b29598559b8aecf733eb66be6e0c439564256f40eb0f6982c
diff --git a/dev-python/keyring/keyring-19.2.0.ebuild b/dev-python/keyring/keyring-19.2.0.ebuild
deleted file mode 100644 (file)
index b3e081b..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides access to the system keyring service"
-HOMEPAGE="https://github.com/jaraco/keyring"
-SRC_URI="https://github.com/jaraco/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-SLOT="0"
-LICENSE="PSF-2"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
-
-RDEPEND="
-       dev-python/secretstorage[${PYTHON_USEDEP}]
-       dev-python/entrypoints[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? ( ${RDEPEND} )
-"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/keyring-19.1.0-tests.patch"
-)
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
-       dev-python/jaraco-packaging dev-python/rst-linker
-
-python_prepare_all() {
-       # avoid a setuptools_scm dependency
-       sed -i "s:use_scm_version=True:version='${PV}',name='${PN//-/.}':" setup.py || die
-       sed -r -i "s:setuptools(_|-)scm[[:space:]]*([><=]{1,2}[[:space:]]*[0-9.a-zA-Z]+|)[[:space:]]*::" \
-               setup.cfg || die
-
-       # avoid other deps
-       sed -i -r "$(printf -- 's:[[:space:]]*--%s::;' --doctest-modules --flake8 --black --cov)" \
-               pytest.ini || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       # Override pytest options to skip flake8
-       # Skip an interactive test
-       pytest -vv --override-ini="addopts=--doctest-modules" \
-               --ignore ${PN}/tests/backends/test_kwallet.py \
-               || die "testsuite failed under ${EPYTHON}"
-}