Version bump. Fixes lots of bugs. Remove old ebuilds.
authorMichael Hanselmann <hansmi@gentoo.org>
Wed, 6 Dec 2006 14:51:47 +0000 (14:51 +0000)
committerMichael Hanselmann <hansmi@gentoo.org>
Wed, 6 Dec 2006 14:51:47 +0000 (14:51 +0000)
Package-Manager: portage-2.1.1-r2

sys-apps/inputd/ChangeLog
sys-apps/inputd/files/digest-inputd-0.0.6 [new file with mode: 0644]
sys-apps/inputd/inputd-0.0.6.ebuild [new file with mode: 0644]

index c0234a49d89ea4cd1c0c549a426072557f06af9c..bcd7d94582e407e499cb909263d7721c11f6353a 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-apps/inputd
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/ChangeLog,v 1.12 2006/11/26 21:32:31 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/ChangeLog,v 1.13 2006/12/06 14:51:47 hansmi Exp $
+
+*inputd-0.0.6 (06 Dec 2006)
+
+  06 Dec 2006; Michael Hanselmann <hansmi@gentoo.org> -inputd-0.0.4.ebuild,
+  -inputd-0.0.4-r1.ebuild, -inputd-0.0.5.ebuild, +inputd-0.0.6.ebuild:
+  Version bump. Fixes lots of bugs. Remove old ebuilds.
 
   26 Nov 2006; RenĂ© Nussbaumer <killerfox@gentoo.org>
   inputd-0.0.5-r1.ebuild:
diff --git a/sys-apps/inputd/files/digest-inputd-0.0.6 b/sys-apps/inputd/files/digest-inputd-0.0.6
new file mode 100644 (file)
index 0000000..fa2809b
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 e93631545ff6be1579fad020c51240ab inputd-0.0.6.tar.bz2 102230
+RMD160 ecf1753ba81cb7b3649a31d708c0fe23446fda36 inputd-0.0.6.tar.bz2 102230
+SHA256 57406373370956173f5e33c7c82ac647f739ee3b70362ce1e2f41ca4c6ae2813 inputd-0.0.6.tar.bz2 102230
diff --git a/sys-apps/inputd/inputd-0.0.6.ebuild b/sys-apps/inputd/inputd-0.0.6.ebuild
new file mode 100644 (file)
index 0000000..6100a71
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/inputd/inputd-0.0.6.ebuild,v 1.1 2006/12/06 14:51:47 hansmi Exp $
+
+inherit eutils
+
+DESCRIPTION="inputd is a user-space daemon to emulate key presses trough other
+key combinations"
+HOMEPAGE="http://hansmi.ch/software/inputd"
+SRC_URI="http://hansmi.ch/download/inputd/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/glib-2.8
+       >=sys-kernel/linux-headers-2.6.16"
+RDEPEND="sys-fs/udev"
+
+src_install() {
+       emake DESTDIR=${D} install || die 'installation failed.'
+
+       newinitd ${FILESDIR}/inputd.init inputd
+       dodoc README doc/FAQ NEWS
+
+       insinto /etc
+       doins doc/inputd.conf
+}
+