Version bump, Cleanup
authorTobias Scherbaum <dertobi123@gentoo.org>
Tue, 26 Dec 2006 23:57:49 +0000 (23:57 +0000)
committerTobias Scherbaum <dertobi123@gentoo.org>
Tue, 26 Dec 2006 23:57:49 +0000 (23:57 +0000)
Package-Manager: portage-2.1.1-r2

net-misc/htpdate/ChangeLog
net-misc/htpdate/files/digest-htpdate-0.9.3 [new file with mode: 0644]
net-misc/htpdate/htpdate-0.9.3.ebuild [new file with mode: 0644]

index da6d2249aa4dc50e4e23a05f2a077956478a071f..324445e0e5f437256687aa89a3a5dffd172155e6 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-misc/htpdate
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/ChangeLog,v 1.24 2006/07/15 07:23:32 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/ChangeLog,v 1.25 2006/12/26 23:57:49 dertobi123 Exp $
+
+*htpdate-0.9.3 (26 Dec 2006)
+
+  26 Dec 2006; Tobias Scherbaum <dertobi123@gentoo.org>
+  -htpdate-0.9.1-r1.ebuild, +htpdate-0.9.3.ebuild:
+  Version bump, Cleanup
 
   15 Jul 2006; Tobias Scherbaum <dertobi123@gentoo.org>
   htpdate-0.9.2.ebuild:
diff --git a/net-misc/htpdate/files/digest-htpdate-0.9.3 b/net-misc/htpdate/files/digest-htpdate-0.9.3
new file mode 100644 (file)
index 0000000..a0c14bb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 de3ef18bcd3c5b63bb41c09af267bea9 htpdate-0.9.3.tar.gz 13904
+RMD160 9edb414b6e1855db3e7a12e53b23a66bdd97a373 htpdate-0.9.3.tar.gz 13904
+SHA256 176aed4237a69382be3d3e26ab47b1e078d3788edfdf696119d957d00adf4584 htpdate-0.9.3.tar.gz 13904
diff --git a/net-misc/htpdate/htpdate-0.9.3.ebuild b/net-misc/htpdate/htpdate-0.9.3.ebuild
new file mode 100644 (file)
index 0000000..e4bcf2d
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/htpdate/htpdate-0.9.3.ebuild,v 1.1 2006/12/26 23:57:49 dertobi123 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Synchronize local workstation with time offered by remote webservers"
+HOMEPAGE="http://www.clevervest.com/htp/"
+SRC_URI="http://www.clevervest.com/htp/archive/c/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~s390 ~sh ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       gunzip htpdate.8.gz || die
+}
+
+src_compile() {
+       emake CFLAGS="-Wall ${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+       dosbin htpdate || die
+       doman htpdate.8
+       dodoc README Changelog
+
+       newconfd "${FILESDIR}"/htpdate.conf htpdate
+       newinitd "${FILESDIR}"/htpdate.init htpdate
+}
+
+pkg_postinst() {
+       einfo "If you would like to run htpdate as a daemon set"
+       einfo "appropriate http servers in /etc/conf.d/htpdate!"
+}